Need help? Check out our Support site, then


Widgets have disappeared from home page sidebar

  1. Friends, I had just put up a new post when all my widgets (8 total) disappeared from the sidebar on the left! I can't think what I could have done. The widgets are all fine when I go to any page other than the home page (/reviews, /book, /events, /about). What can I do to restore them on the home page?

    Thanks very much for your help.

    The blog I need help with is tsusanchang.wordpress.com.

  2. A little info to add to the above: when I unpublish the last post, the home page returns to normal and I can see my widgets again. I'm not sure what it is about this post that is making the widgets disappear from the home page. When I click on the post itself, the widgets re-appear.

  3. OK, although I did search for an answer, I didn't till now find a post that pointed to the tags as a problem. I think I've solved it. Thanks.

  4. Your widgets do appear on your homepage at the very bottom below the posts. If you have been copying and pasting text from elsewhere without using either icon 5 or icon 6 in Row 2 of the visual editor, please see here http://en.support.wordpress.com/visual-editor/#pasting-text Typically this is caused by an open HTML tag in one of your posts and it sounds like your most recent post is the one that is creating this issue.

    Go to Settings>Writing, tick the option "WordPress should correct invalidly nested XHTML automatically", click Save Changes, then edit the post (make any change such as adding then deleting a space or something) and click Update.

    Posts > All Posts, change all your latest posts to Draft, click Update, change them back to Published, click Update again. (You can edit all of them at once: tick the square in front of their titles then select Edit from the Bulk Actions dropdown and click Apply.)

  5. Many thanks timethief. I hope others find this information more efficiently than I did!

Topic Closed

This topic has been closed to new replies.

About this Topic