Need help? Check out our Support site, then


widgets not right on main page

  1. truthinreligionandpolitics
    Member

    for some reason the side bar widgets are now appearing on the bottom of the main page only. they used to be correctly displayed to the right of the body. they are displayed correctly on every other page on the blog, what could this possibly be?

    in the widget editor they are shown as being where they are supposed to be, and i have nothing in place where the bottom bar can have widgets, it is empty.

  2. Sidebar at the bottom is typically due to bad html in one or more posts. When something like that happens, you must first click the title of each post to see which post causes the problem (in your case it's "Essence of Christianity 1").

    Next, go to Settings>Writing, tick the option "WordPress should correct invalidly nested XHTML automatically", click Save Changes. Then edit the problem post (make any insignificant change, e.g. add then remove a space) and click Update Post.

    PS Leave the option on, to make sure this particular problem won't crop up again.

  3. truthinreligionandpolitics
    Member

    worked like a charm, so what exactly was the problem and how was it obvious to you?

    i appreciate the help

  4. You're welcome.

    The problem was an unclosed tag in the code of your post. All opening HTML tags that say "format the content in such and such a way from this point on" must have a corresponding closing tag that says "up to this point"; if the closing tag is missing, the command will affect everything that follows on the same page (including your sidebar).

    Your question is one of the most frequently asked questions: if you had searched the forum for "sidebar at the bottom" you would have found many previous replies. So it was obvious to me, as it is to all experienced volunteers here, because it's a common problem. (And because it's a common problem, as well as because "invalidly nested XHTML" probably means nothing to the average user, we are baffled as to why WP keeps the default for that option to off instead of on.)

Topic Closed

This topic has been closed to new replies.

About this Topic