Need help? Check out our Support site, then


Widgets work in mobile mode, but not in full site mode

  1. nbalinebreaker
    Member

    My WordPress.com blog uses Standard and has only two widgets: Text and Twitter Timeline.

    Both work when I pull up the site on a PC, and the site looks the way I want it to look there.

    If I view in Mobile mode on an Android phone, both widgets work, but I also get Standard's generic Mobile layout for the rest of the site. Which I don't like at all.

    If I switch to Full Site mode on an Android phone, I get the layout I prefer, but neither widget works.

    The layout matters, and functions matter too. I want both. Not either/or.

    Can you fix this problem?

    The blog I need help with is nbalinebreaker.com.

  2. Standard is a responsive width theme.

    Responsive width means the layout adapts depending on the size of the device being used to view your site. When responsive width themes are viewed on mobiles sidebars appear below the posts in order to provide as much space as possible for reading.

    If you have enabled the mobile theme here > Appearance > Mobile then disable it.

  3. nbalinebreaker
    Member

    timethief,

    Thanks for responding, but that's not the problem. I know that in Mobile mode, the layout shifts from two columns to 1, and the widgets appear below.

    The problem is that both the Text and Twitter Timeline Widgets come up as blanks in Full Site mode on a mobile device. If I switch to Mobile Mode, they appear, but then the menu, look & feel I prefer is replaced by Standard's Mobile layout, which looks terrible.

    I did not have this problem with the Twitter widget, which has been replaced by Twitter Timeline in WordPress. Right now, my current options are Bad Layout/Widgets Work, or Good Layout/Widgets Don't Work. I'd like the Full Site option to appear with working widgets on mobile devices.

  4. I've replicated this issue using Chrome 26. I've flagged this for a Staff member to review, as it appears to be a JavaScript issue or something when resizing the browser window. If you refresh the page after resizing the window, the widget content reappears.

  5. nbalinebreaker
    Member

    andrew,

    It's not working on my Android phone. Sometimes the Text widget appears, but the Twitter Timeline never works in Full Site mode.

    Thanks for replying so quickly, and for flagging this. I'll try refreshing a few more times, but ultimately I need this to work the first time for users. In any event, I appreciate the help.

  6. @nbalinebreaker My last comment was meant more for the moderator than for you. I've replicated the issue and confirmed that it is an issue with the theme, and not your browser. A staff member should be able to connect with the right person to fix this issue. In the mean time, using another theme might suffice. The twitter timeline widget works with most themes, so it seems to be a conflict with this particular theme.

  7. nbalinebreaker
    Member

    andrew,

    Okay. Thanks again for the help.

  8. In this case, I recommend contacting the developer directly for help: http://premium-themes.forums.wordpress.com/forum/standard

    For future reference, there will be a link for the specific Premium Theme support forum under Appearance -> Themes in your blog’s Dashboard, but the theme needs to be active and you need to be signed in as the user who purchased it in order to see it.

  9. macmanx,

    Thanks.

  10. You're welcome!

  11. nbalinebreaker
    Member

    Replacing the Standard theme with Book Lite solves my problem, but not Standard's. In any event, I'm switching. Thanks to all for the timely replies. They're much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic