Need help? Check out our Support site, then


"Windows Live Writer" won't upload images to WordPress

  1. Hello, everyone!

    I thought I'd finally solved my blogging woes with the discovery of Windows Live Writer. My first post using Windows Live Writer worked perfectly. I typed the post in Live Writer, inserted many images in Live Writer, and then uploaded ("published") it to my WordPress Blog. Everything was fine.

    I tried to do the exact same thing today (having changed nothing on my computer or my blog), and now I get this error message:

    "Image Upload Not Supported by Weblog
    The following images cannot be published because the weblog does not support image publishing."

    Then it lists all the images in the post and suggests that I "configure an FTP account for image publishing." I have no idea what that means and wouldn't even know how to begin.

    Does anyone know why I suddenly can't upload images using Windows Live Writer? Is this a problem with Live Writer, with WordPress, or with my computer? Is there an easy way to fix this? I'm puzzled because, as I said, it worked perfectly the first time.

    Here is a link to my blog:

    http://tirugondar.wordpress.com/

    I'm using the Journalist theme. And the only thing that I've done differently is that I started blogging some photos directly from my Flickr account at:

    http://www.flickr.com/photos/dougnienhuis/

    That has worked very well, and I haven't had any problems. It is only when I try to publish a post from Windows Live Writer with inserted images that I get this error.

    BTW, I think I'm using the latest version of Live Writer. It is:

    Version 2008 (Build 12.0.1370.325)

    Thanks very much for any help or advice!

    Doug

  2. What kind of files are the images? WP.com doesn't support bitmaps, for instance.

  3. Hi, Raincoaster,

    I'm sorry. I should have included that info in the post. They are all jpegs. The first post that worked also contained only jpegs.

    Doug

  4. I'm wondering if it's something that's changed on Flickr's end. I know staff were tinkering with images earlier today, but it seems they're pretty much finished that (although if I could get my Blogroll back it would be nice).

    Try saving from your Flickr stream to your hard drive and uploading from there. Report back if that works or doesn't.

  5. I just published a photo using the same build of Livewriter and it worked fine.
    Perhaps you could try in Livewriter to go to Tools>Options>Accounts and select the blog in question and edit that account and find the little link that states capabilities for that account and see if file upload says yes or no.
    Then you might try to go into images there and see that upload to weblog is the radio button that is selected (FTP won't work here)
    Other than that you might have to delete the account in Livewriter and remake it to get the settings right.
    I think it is possible that if there has been some adjustment at WordPress then Livewriter may need to readjust something also.
    The reason I say that is I take mirrors of my websites as backups every now and then and there are often changes in admin file things.

  6. Hi, again,

    The images that won't upload right now ARE from my hard drive, just like the original post that did work. I only mentioned the Flickr images, because I'm also posting directly from Flickr to my WordPress blog. And that works fine.

    Wait a second: I think I just solved my own problem (by accident!).

    I took another look at the pictures I'd inserted into my post on Windows Live Writer. I noticed that in the options on the right side of the page, the "Link To" option was set to "Source Picture." I had no idea if it would make any difference, but I changed that to "Link To" "None", and then I tried to publish the post again.

    This time it worked fine. The post and the images uploaded to WordPress perfectly.

    I can't remember what the setting was on the first post that worked. I'm assuming it was set to "Link To" "None". The default setting must have changed somehow to "Source Picture" and it was that setting that wasn't working. I'm guessing that when I blogged pictures from Flickr, it changed that setting, and then it didn't go back to the original setting.

    There are three choices in the "Link To" drop down menu:

    Source Picture
    URL
    None

    It looks like when you are inserting pictures from the hard drive on your computer, "None" is the setting you want. That makes sense. Certainly, the "Source Picture" option wasn't working for me.

    Well, that seems to have sorted itself out. Thanks for your help, Raincoaster.

    Doug

  7. Great, thanks for posting the solution!

  8. If you post a picture as link to source picture, this uploads 2 images, one is the size you want, i.e. 400 wide, and the second picture is the source, which is the original image without being resized. The reason why it does this is so when you click on the picture another window will open and show the original size file. So if like me you have massive pictures due to 10mp high resolution then you fill find that live writer can either time out or tell you that the image is not supported.

    I tend to resize the pictures so that this does not happen, that is why you managed to upload the image when you selected none, as you only got the resized version

Topic Closed

This topic has been closed to new replies.

About this Topic