Need help? Check out our Support site, then


Windows Live Writer XmlRpc Issue

  1. Hello.

    I have searched the forum for a solution to this and read through http://en.forums.wordpress.com/topic.php?id=21616&replies=5, but I can't seem to resolve this issue. The topic is now closed and it doesn't give a solution or say if it's for hosted (free) vs. non-hosted blogs.

    I host my own WordPress blogs and when I use Windows Live Writer to post using XP, I get this message:

    An unexpected error has occurred while attempting to log in:
    Invalid server response - the response to the blogger.getUsersblogs method received from the weblog server was invalid:
    Invalid response document returned from XmlRpc server

    When I post using Vista from my laptop, it goes through, but it doesn't post. When I go into the dashboard, there was nothing I could do to get it to go live. I had to delete the post and recreate it.

    I have also tried uninstalling WLW and reinstalling it without success.

    Is there a solution to this somewhere that I'm missing?

  2. There is probably a plugin that is causing invalid XML to be included in the response. I recall a few people mentioning this in connection with the Google Sitemaps plugin. Try disabling your plugins one at a time and see if that solves the problem.

  3. Also, about the thread you linked to, that was only for WordPress.com users, not self hosted blogs.

Topic Closed

This topic has been closed to new replies.

About this Topic