Need help? Check out our Support site, then


Wonky layout when change theme to Nishita

  1. sarahleggephotography
    Member

    Hi,

    I'm trying to change my theme from black letter head to nishita. When I activate Nishita (I've tried a few times) I upload a new header, select the narrower option, select some widgets for the right hand side. I then check what it looks like and there is no right hand column of widgets, I think the layout is wide and the first blog post starts over the header image (which must be an error rather than an option as no-one would choose for it to look like that). I've had to switch back to the old theme but I have a screen shot, but I don't think I can upload it here.

    I've done it a few times but it always happens. Something similarly odd happened when I tried to activate a different theme instead.

    I think wordpress support is closed this weekend and I was hoping to get the new blog look sorted this weekend....does anyone have any suggestions?

    Thank you,
    Sarah

    The blog I need help with is sarahleggephotography.wordpress.com.

  2. To show us the screenshot, upload it to your blog via Media > Add New, copy its URL and paste it here.

  3. sarahleggephotography
    Member

  4. Of course the theme is not supposed to look like that. But I'm afraid this screenshot alone can't tell us what's wrong: you'll have to switch to Nishita again so we can check the blog.

    Also, you have the CSS upgrade, don't you? How did you make the changes you've made? By adding specific commands to the CSS editor or by pasting the whole stylesheet and making changes to it?

  5. sarahleggephotography
    Member

    OK - have switched to Nishita now http://sarahleggephotography.wordpress.com/.

    I do have CSS upgrade but I haven't touched that - I just clicked on 'activate' on Nishita in themes, then went to theme options to select the narrower option, then went to widgets to move a few widgets to the right hand column.

    Thanks for your help.

  6. sarahleggephotography
    Member

    Sorry, to clarify - I haven't made any recent CSS changes. I made one change a couple of years ago to change the colour of the header font from orange to pink....I'm afraid I can't remember whether I just went into the CSS and changed the font number or whether I copied and pasted. Even just changing the font was stretching my ability!

  7. This is seriously messed up! It's not just what your screenshot displayed - everything is wrong. I suggest you start by going to Appearance > Custom Design > CSS: delete everything from the CSS editor and save. Also, please go to Media > Add New, upload the original file you uploaded as your header image, copy its URL and paste it here.

  8. sarahleggephotography
    Member

    Oh dear, not sure how I got into this mess! Thanks so much for your help. I've deleted that (I left the second radio button checked, about just using my style sheet, hope that was right), and here's the link http://sarahleggephotography.files.wordpress.com/2011/10/whole-pic-header-nadia-out-of-church22.jpg

  9. Don't thank me yet: so far I'm groping with a problem I've never seen before!

    1) No, you must delete everything from your CSS editor and check the first radio button (which will leave the original CSS of the theme untouched).

    2) I don't think that's the cause of the problem, but anyway the file you used for your header image was an impossibly large one. Try copying and uploading this resized version:
    http://wpbtips.files.wordpress.com/2011/10/nadianew.jpg

  10. sarahleggephotography
    Member

    Ooh I've done that and I think it's fixed! Do you agree? Thanks so much for your time!

  11. Yep, that's Nishita like Nishita should be - success!

    A couple of other suggestions:

    • You've been uploading downsized versions of your images, which is quite correct. But in this case there's no point having them link to the same image alone. In my opinion you should make them non-clickable. See here:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    • Your front page takes too long to load because of all the images; for a visitor with a slow connection it might even time out before loading them all. You should limit the number of posts per page to only a few (in Settings > Reading). You could also use the read-more tag as well, to truncate the posts:
    http://en.support.wordpress.com/splitting-content/more-tag/
    Or you can display the images in each post as a gallery (set of thumbnails that link to larger versions when clicked):
    http://en.support.wordpress.com/images/gallery/
    (Looks good only if all the images of a set are in the same format.)

  12. sarahleggephotography
    Member

    Fab, thanks a lot for your help and for the extra tips, I'll change that option when I'm uploading pics. Just one extra question (sorry) - now I'm showing bigger portrait orientation images (in my latest 2 posts) they don't seem quite as crisp as the original file, or the image when I click on it - any suggestions for how to improve that?

    Thanks and have a good weekend,
    Sarah

  13. You're welcome.

    Images lose quality when downsized by WP. So the solution is to downsize copies of your images (using an image editing application) to the desired width* and upload those copies. See here:
    http://wpbtips.wordpress.com/2010/01/16/image-quality/

    * For the web, width means width in pixels. To get an idea of what widths you should be aiming for, in case you're not familiar with that unit, the images in your latest posts are 450px wide (I mean the displayed versions, not the originals).

  14. sarahleggephotography
    Member

    Ah, perfect, thank you.

  15. You're welcome!

  16. sarahleggephotography
    Member

    Erm, sorry to come back again (promise not to ask any more ques after this!) and perhaps should post a new question but maybe is related to previous issue - just checked out my latest blog post (which has lovely sharp images thanks to your advice) and looks fine on chrome but on internet explorer the images look stretched....any ideas?
    http://sarahleggephotography.wordpress.com/2011/10/02/charlie-and-friends/

  17. You'll get even better results (and possibly avoid the IE issue too) if you resize
    your images to a width not exceeding the maximum for the Nishita layout you're using. For that layout, maximum width is 518px.

    The issue on IE might have to do with the browser (because IE isn't a good one) but it might have to do with the theme too. In either case, better report this to staff:
    http://en.support.wordpress.com/contact/
    Make sure you tell them which version of IE you're using.

  18. sarahleggephotography
    Member

    Ah, thank you - sorry, thought I'd followed your instructions but I resized to 700-something wide, which I now realise was column width not image width. I will also report the ie issue.

    Thanks again.

  19. The 768 you probably saw in the quick info for the theme is for the narrow layout without sidebar. More detailed info on these things here:
    http://wpbtips.wordpress.com/2009/07/23/maximum-image-width/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags