Need help? Check out our Support site, then


Wont let me add tags to post today

  1. Every time I try to add a tag to my post it refreshes the page and saves a draft... it wont let me add any tags... even when I try adding them from most used tags, or suggested tags... it will add the suggested tags but no others and it won't let me type more (the add tags writing stays on the space where you would type the tags you want to add)

    The blog I need help with is chasek8.wordpress.com.

  2. I take it you are editing and trying to add more tags. I have viewed your blog. You are using too many tags. The aim of assigning categories and tags is to use a s few as possible and use only those that are relevant. This is the rule of thumb and overuse of tagging is referred to as spamdexing. Spamdexing here means your posts will not be displayed on the wordpress.com global tag pages and can't bring you traffic as they won't be there. From Google's POV when when dealing with persistent and prolonged spamdexers they do not display the indexed posts in the main index but drop it into supplementary pages. See here please for reasons posts aren't displaying on the global tag pages. > http://en.support.wordpress.com/global-tags/#missing-posts

  3. Hi there and thanks for the info... but I am NOT editing and trying to add more tags...and I am aware that I have a large amount of tags on each post... I have been working to clear them out slowly..... But my issue today is that I can't add ANY tags to a NEW post... not even the suggested tags that wordpress generates...

  4. Have you tried any troubleshooting? You could have a browser issue so try changing your browser settings, refreshing the page, or clearing the browser cache and cookies - instructions for specific browsers.

    Which browser and version of it are you using?

  5. I am using Google Chrome, but I have tried all those options.. I am going to attempt them again and hopefully it will sort the issue out...

  6. Do you have another browser you can try like Firefox which works well on wordpress?

  7. I will try from my internet explorer.... I'll update you shortly... Thanks for the suggestion... I just did not try IE because I find it is SO slow....lol

  8. harrymccracken
    Member

    I'm having the same problem; it seems to be a Chrome issue.

  9. Yeah I couldn't deal with IE because it is sooo slow, so instead I downloaded firefox and now the issue has been resolved... I guess it's bye bye chrome...hello firefox for me! :) LOL

  10. @chasek8
    I'm glad to hear Firefox is working well for you. Happy blogging! :)

    @harrymccracken
    Yes it does. So have you tried Firefox yet or not?

Topic Closed

This topic has been closed to new replies.

About this Topic