Need help? Check out our Support site, then


WordPress RSS feed not working.

  1. Hi there. This is my first attempt at setting up a podcast and have uploaded seven different mp3 messages for our church website so far. I'm using WordPress.com, Archive.org and FeedBurner and for the most part, it is all working. The intention is to included an RSS feed to iTunes to make the subscription process much easier for people who wish to keep up to date with, or to download, the latest messages but so far, I can't work out what to do at what I hope is my last hurdle. FeedBurners Feedmedic says that all is well, however Podmedic comes up with - "The content type returned from your host server was a text type, not a binary media type. Podcast content should always return a binary media type, such as audio/mpeg for audio, or video/mpeg for video." I've researched as much as I can, but can't work out what I need to do to fix this. Can anyone steer me through a solution please as when I test the Podcast at iTunes, it accepts the Podcast ok, but does not have any of the attached messages. I suspect it is to do with "enclosures", but do not know how to fix this.
    Thanks for any help.
    Warwick

    The blog I need help with is pukekohecommunitychurch.wordpress.com.

  2. I'm sorry but I have no experience with podcasting. All I can do is provide the link http://en.support.wordpress.com/audio/podcasting/ and then tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  3. Howdy,

    Have you reviewed the link from timethief at http://en.support.wordpress.com/audio/podcasting/ , specifically the Feedburner instructions for denoting that it is a podcast?

    If you could send over a link to a post being used for the podcast as well as the feed URL you're using, that would be very helpful too.

    Cheers!

  4. Hi and thanks for your help and interest in solving my problems for me :) Sorry about the delay in responding but have spent most of the last two days in airplanes. I've gone over the link kindly provided by timethief but still not solved the issue. It appears to be in the way that I have the feed setup with Feedburner. It says that my feed is a web page and not a feed? Here is the link to one of the posts - http://pukekohecommunitychurch.wordpress.com/2013/10/07/its-all-about-the-heart/, and here is the feed URL that I am using - http://pukekohecommunitychurch.wordpress.com/wp-admin/edit.php?category_name=christian-teaching. Hope this helps.

  5. That is the wrong URL. That is an administrator's editing view of a category, and nobody but the blog admin can access that page.

    I believe the feed URL you want is http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed if you want all your podcast posts in the feed.

  6. Thanks raincoaster as that has removed the podmedic errors. When I try to subscribe to the podcast within iTunes to test the podcast however, it still does not have any of the seven current mp3 messages. Is there something else that I still haven't got right yet?

  7. I'm afraid that's the limit of my knowledge. Try the other threads on http://en.forums.wordpress.com/tags/itunes and http://en.forums.wordpress.com/tags/podcasts

  8. Thanks for trying. I'm sure we're getting there slowly. Probably just one more small correction and it'll be iTunes compatible. Only other issue to resolve is where and how to store the PNG graphic for use as the iTunes cover picture.

  9. Howdy,

    Hope y'all had a great weekend. What is the address you're using to subscribe in iTunes? I'd like to test on my end so we have the same end goal to consider everything working.

    It should be, per our instructions and if I'm understanding your setup correctly, the FeedBurner URL. (The http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed is used within FeedBurner, then the Feedburner URL is what you tell folks to use to subscribe to the podcast with).

    Peace!

  10. Gidday up there. Weekend weather was a bit wild and windy down here, otherwise all good. Hope your weekend went well for you too :) The address that I used for the iTunes subscription test was initially the Feedburner feed address of http://feeds.feedburner.com/PukekoheCommunityChurch-SharedMessagesPodcast , but then in the process of error elimination, I changed it to the "original" feed of http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed
    End result in the test was the same either way, with test pass as far as iTunes was concerned, but zero episodes subscribed. I'm pretty sure that the fault must be mine, but do not know what I am doing wrong? The title of the subscribed podcast when shown in iTunes is
    Pukekohe Community Church - Shared Messages » podcast but in Feedburner it is Pukekohe Community Church - Shared Messages
    How do I stop it from displaying the bit at the end in iTunes? ( » podcast ), that is, after we get it to show the episodes.

  11. It was wet! I'm in Austin; one area of town had 11 inches in 7 hours—a quarter of our annual average rainfall! No arks needed...yet.

    When you edit your podcast at Feedburner, click on "Edit Feed Details..." and ensure the following settings: Feed Title: Pukekohe Community Church - Shared Messages Original Feed: http://pukekohecommunitychurch.wordpress.com/tag/podcast/feed Feed Address: (whatever you like, but something like "PukekoheCommunityChurch" should be fine. Shorter may be better if folks ever need to manually type it in.

    Then click the Optimize tab and make sure the "Create podcast enclosures from..." option to set either to any rich media file or audio files only.

    After saving all of that, subscribing using the FeedBurner link should work in iTunes (may need a little time to let the caches reset).

    Can you let me know once you've done/confirmed those things?

    Cheers!

  12. All checked. Only change made was to the Feed Address name which I shortened up to your suggested option. Podcast enclosures were already as you asked although it had dropped the category for some reason and so I reinserted it as "Religion and Spirituality", subcategory of "Christianity" I'm not sure if there is an issue with our feed or Feedburner, but any editing of the feed at the moment generates a "Trouble at the Mill!" message when changes are saved. Hopefully that will take care of itself, as it suggests?

  13. Might pay to start collecting wood though. At least enough for a raft ;)

  14. Hopefully so.

    I did notice that I'm seeing something slightly different on the feed's FeedBurner page now: https://cloudup.com/cO1e3F5szaI

    Before it wasn't telling me that it was rich media and highlighting iTunes as an option.

    At the moment, I think it is a FeedBurner issue. Maybe let's give it a few hours or a day, then try again to shorten the name?

  15. Sounds good. What time do you usually finish up for the day? I'm going to be away from having internet access from later this evening until about this time Friday (NZDT) . (its 10am Tuesday here)

  16. Today, I'll wrap up a little after 17:00 UTC-5 or in about an hour.

    It sounds to me that everything is set correctly. I'll try to subscribe via iTunes again first thing tomorrow morning and see if there is anything else on my end I can test if it isn't working.

  17. Thanks Brandon. Were UTC +13 so should be able to check back on Thursday between 1 and 5pm your time.

  18. Looking forward to it! Have a great week in the meantime.

  19. Hi Brandon. Hope your ark building is still on hold and plenty of sunshine about :) Just back into internet reception and checked the site with mixed results. Feedburner now responding to editing ok, and so have successfully changed the Feed Address to "PukekoheCommunityChurch" on the edit page. This is not reflecting anywhere else though, but assume that it will after a period of time? iTunes option is still showing, as is the comment re rich media, however, iTunes still shows zero episodes and the following errors are showing on the Feedburner podmedic. 1)Media enclosure not created because: The content type returned from your host server was a text type, not a binary media type. Podcast content should always return a binary media type, such as audio/mpeg for audio, or video/mpeg for video. and 2) Media enclosure not created because: The URL was unavailable or FeedBurner could not receive a response within 10 seconds. Error #1 is shown twice for each episode followed by error #2 five times for each episode and then error #1 again, for each episode. Bad hair day, or straight forward fix??

  20. I'm diving into a few things to see if I can get to the bottom of this.

    The ground is still wet, but the ark project is a few notches down on the list. :-)

    I'll give you an update in a short bit.

  21. Howdy,

    Sorry for the delay!

    First, I must apologize. I overlooked that you were using the archiveorg shortcode. So good news, I found the issue. Bad news is I could have caught it sooner :-/

    To make up for it, I've fixed all of your current posts so they work and gifted you a 10 GB space upgrade for the year.

    How to do it so it works moving forward: Two ways. One depends on WordPress.com's space upgrade being active. With this option, you can continue using it until you run out of space or the upgrade expires. If it expires, everything already uploaded will stay, but nothing more can be uploaded.

    1. Prepare the MP3 audio file as normal.
    2. Start your WordPress.com post as normal.
    3. Instead of doing anything at archive.org, instead, click the Add Media link in the post editor.
    4. Upload the MP3 file in the pop-up that shows up.
    5. After it is uploaded, insert it into the post. It'll appear in the editor like [audio http://example.files.wordpress.com/2013/10/file-name.mp3]
    6. Save your post. Done!

    Option 2 is along the same lines as you're doing now, tweaked it work. I didn't test this since I don't have an account at archive.org, but happy to figure out any issues that may come up if this doesn't work.

    1. When saving the audio file, use all lower case, no spaces and no special characters, except hyphens. e.g. pastor-hill-sermon.mp3 and NOT Pastor Hill Sermon Today!.mp3. (All of the current audio files have spaces, which is why I believe this didn't work for me initially).
    2. Upload to archive.org as before.
    3. On the audio's details page, e.g. https://archive.org/details/PastorJillSmithWhatItIsToBeThePeopleOfGod , right-click or option-click on the size of the file under VBR MP3. See here: https://cloudup.com/cpwOIaCeTil
    4. Click Copy Link
    5. In the WordPress.com editor, manually type [audio
    6. Paste the address so it appears like [audio https://archive.org/download/PastorJillSmithWhatItIsToBeThePeopleOfGod/PeopleofGod.mp3 ]
    7. Save post. Done!

    Please let me know if you have any questions. My apologies again for missing this the first go around.

  22. Eureka! Thank you :) I'll explore all the options later today in the chance that I might catch you before you leave for the day. I checked the iTunes podcast subscriptions and there was a download waiting for me. Very exciting. There are two details to resolve before I can submit the podcast to iTunes. The two issues are name and title picture. The iTunes podcast test still shows the extra bit at the end of the title, and I'm not sure how to go about inserting the title cover without it becoming another download to every one. If we can fix these two things I should be able to submit the podcast to iTunes tomorrow. Thanks again, you're a godsend :)
    Blessings
    Warwick.

  23. Hi Brandon. Trust you slept well with the weight of our issues solved :) I had a great day following your breakthrough and have the picture loaded for iTunes and pretty much set to go bar the tidy up of the labels. I tried to get the iTunes heading to read "Pukekohe Community Church", with the sub title in small font of "Connecting People with Kingdom Life & Purpose in Christ". (removing the "- Shared Messages" ) On the SmartCast page of Feedburner, the sub title details are already loaded, along with "We are motivated by the mission of sharing the good news of Jesus Christ in Pukekohe, the Franklin District, New Zealand and beyond." in the podcast summary option. Its not important to have the summary option if there isn't enough room to display everything so if its an issue, then I'll leave it out. The only other thing that I've noticed, is when you view the podcasts on either a smart phone or laptop, and select the area that gives you a summary about that particular podcast, it displays a lot of superfluous information that I would prefer not to be displayed. Its worse when the episode summary is brief, as in "What it is to be "The People of God". All the information regarding "Filed Under" and "Tagged" etc, is either partially or completely displayed, depending on space. Is there a way to prevent that? (In the above case, even the coding of the audio is displayed when viewed with in iTunes) These are the last two points to resolve and then hopefully I can submit it to iTunes tomorrow :)

  24. Regarding the extra information:

    We can do better. The "Continued Reading" line will remain, but we can handle the rest. When writing the post in WordPress, there is an extra box for "Excerpt". If you include the description there (as well as the main editor), Feedburner will use the Excerpt for iTunes, instead of however much of the main post content will fit.

    If you don't seen Excerpt, try ensuring it is enabled via Screen Options.

    For the shorter title, have you tried editing the feed in Feedburner? Go to http://feeds.feedburner.com and click on the feed name. Then click on Edit Feed Details. That *should* be the place you'll need to change it, but I could be wrong.

    How does that work for you?

    Cheers!

  25. Not working on either account at this stage. I had already tried to sort the name out in Feedburner and it is displaying correctly on the edit feed details - Feed Title, just not in the title when you click on the RSS link, or in iTunes. When I tried to use the excerpt button, I couldn't find it and it appears its not an option in the theme that I am using. (Reddle) The support section showed me how to use the "more" tab and I thought it said that it would work the same way but after inserting it on each post, there is no change, although for some reason, the post "What it is to be the people of God" now displays perfectly in iTunes, with or without the "more tab ???

  26. Excerpt should be an option—I tested it out on "The People of God", with the excerpt. Let me jump in and see if I can force it onto your screen.

  27. It wasn't selected via the Screen Options field. You should see it now under the main blog content (and under the "Related Content" field).

    I'm not sure about the title. It seems to be an issue with Feedburner that I can't duplicate on my test account.

  28. Talk about primed and ready to go! That was quick, and correct :) I thought maybe my eye sight was going as its not listed under screen options if you are on the "posts" or "all posts" pages, until you actually select the post, and then look under screen options. Sanity restored ;)
    1 down and 1 to go.... When you say that you can't duplicate the title issues on your test account, do you mean you are seeing something different, or just can't get to the same screens?

  29. When I change the feed title in details, it changes it elsewhere.

    Googling around, I found an alternative way. Within Feedburner, click on the Optimize tab, then the Title/Description Burner option.

    Let's hope that gets everything straightened out for us!

  30. I think we are done :) I was surprised that when you change the feed details it changed elsewhere, as that doesn't happen when I do the same. I did try the Title/Description Burner though and had a 50:50 success, but got the most important 50%. The name has changed successfully but the description seems to have disappeared into the great black void. It may be displaying somewhere, but exactly where, I do not know. No matter, end result is we are ready to submit the podcast. I can't thank you enough for a job well done. Your persistence and help are very much appreciated. Have a greater weekend in a hopefully sunny Austin :) God Bless, Warwick.

Topic Closed

This topic has been closed to new replies.

About this Topic

  • Started 11 months ago by pukekohecommunitychurch
  • This topic has 35 posts
  • 4 posters
  • Latest reply from pukekohecommunitychurch
  • This topic is not resolved
  • RSS feed for this topic