Need help? Check out our Support site, then


WordPress.com Quadruple Spacing Glitch When Publishing/Updating Posts

  1. Hello,

    I would like to report a WordPress.com glitch that happens about 50% of the time when publishing/updating posts, where the published/updated post magically is quadruple spaced after clicking Publish/Update, and this has been happening for years and/or since I first started using WordPress.com but I never reported it before since I did not use to post as much as I do now for this to be a big problem.

    I am not sure if this is a problem with the Spell/Grammar Check System causing this and/or Zemanta and/or something else, but this happens a lot.

    When ever this happens, which is very often (more than 50% of the time now, pretty much every day & almost every time I publish/update a post), I have to click Edit & Update the post again (sometimes more than once) for it to return to normal double spacing instead of quadruple spacing.

    Anyway, I just wanted to report this finally to see if someone could fix this and/or help figure out what is going on here.

    Thank you,
    -John Jr

    The blog I need help with is goodjohnjr.wordpress.com.

  2. I forgot to mention that I also use The More Tag on all my posts, so maybe that and/or one or more of the other things that I mentioned could cause this problem, who knows.

  3. That's very weird. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/

    P.S. I tagged this thread for a Staff follow-up. Please subscribe to it, so you are notified when they respond.

  4. Hello TimeThief,

    This has been happening for years, I usually use Mozilla Firefox always updated, I am currently using the current version 18.0.2.

    I always have Firefox set to permanent private mode, so all history/cookies/cache/temporary internet files/et cetera are cleared when I exit the browser, and if anything is missed I have CCleaner set to clear these things every time my computer starts up.

    I have third party cookies enabled, and almost always have it enabled.

    I use the extensions: Web Of Trust, Video Download Helper, HTTPS Everywhere (I have not been using this very long), and Adblock Plus (Easy List & Malware Domains List).

    I have HTTPS enabled (since almost the beginning of when I started using WordPress.com), and I almost always try to use the HTTPS versions of websites when possible.

    Thank you,
    -John Jr

  5. Thanks for the updated information for Staff use. Please be patient while waiting noting that it's the weekend.

  6. Okay TimeThief, thank you. :)

    I forgot to mention that I restarted Firefox in Safe Mode with all extensions disabled, and I was still able to get this glitch.

    Here is some more information that they might find helpful in trying to replicate this glitch whenever they get around to it one day:

    1. I create a title & assign a category.

    2. I type the body text, spacing after every sentence.

    3. I use Zemanta for recommended tags, recommended links, related articles, and one media gallery image (almost always from Wikipedia/Wikimedia) Centered at the top of the page.

    4. I use the WordPress.com Proofread Writing Button, and I have my Proofreading Settings set to:

    "Automatically proofread content when:

    A post or page is first published
    A post or page is updated

    English Options

    Enable proofreading for the following grammar and style rules when writing posts and pages:

    Bias Language
    Clichés
    Complex Phrases
    Diacritical Marks
    Double Negatives
    Hidden Verbs
    Jargon
    Passive Voice
    Phrases to Avoid
    Redundant Phrases

    Learn more about these options.

    Language

    The proofreader supports English, French, German, Portuguese, and Spanish. Your blog language value is the default proofreading language.

    Use automatically detected language to proofread posts and pages "

    5. Then I publish/update the post.

    The glitch only happens most of the time (a bit more than 50% of the time), but not all of the time.

    Screenshot of Edit Post screen:

    http://www.use.com/1a3f5f50d709822e4c31#photo=1

    Screenshot after Publish/Update:

    http://www.use.com/1a3f5f50d709822e4c31#photo=2

    Thank you,
    -John Jr

  7. Hi there John Jr.,

    When you write your posts, do you write in the Editor? It sounds like you do, but I just want to confirm.

    After you write a post, could you switch from Visual to Text and take a screenshot of what you see there?

    Thanks so much! I'm very sorry you've been having this issue for so long!

  8. Hello Zandyring,

    When I type posts I go to the Dashboard | Posts | Add New, and I use Visual.

    Here is a screenshot of a post (Text) that is not quadrupled spaced but was until I did my normal fix of Updating it one or more times until the spacing returns to normal:

    http://www.use.com/images/s_2/c4c3fda70f45202b157b_1.jpg

    Here are screenshots of a test post that is quadrupled spaced:

    http://www.use.com/images/s_2/c4c3fda70f45202b157b_2.jpg?is=true&ps=true&rand=528676148178

    http://www.use.com/images/s_2/c4c3fda70f45202b157b_3.jpg?is=true&ps=true&rand=2806080233

    http://www.use.com/images/s_2/c4c3fda70f45202b157b_4.jpg?is=true&ps=true&rand=449659923466

    You are welcome, no problem, it is my fault for not reporting it long ago. :D

  9. I noticed that the quadruple spaced version had the symbol for Non-Breaking Space behind each sentence:

    http://en.wikipedia.org/wiki/Non-breaking_space

    I wonder could this WordPress.com setting be part of the problem:

    "Writing Settings
    Formatting
    WordPress should correct invalidly nested XHTML automatically "

    I use the Enter key on my keyboard after every sentence, I like to space after each sentence to make my posts/text easier to read.

  10. Hi John Jr.,

    As you compose a post, you hit enter once after each sentence, correct? This workflow shouldn't introduce additional spacing for you - so you're right that this could be an issue.

    Did you just enable the checkmark for correcting invalid XHTML, or has it been enabled all along? Would you care to try switching it up and writing a draft post to see if this does indeed solve your issue?

    Cheers!

  11. Hello Zandyring,

    Yes, as I type I use the enter key after each sentence.

    No, I have had that setting enabled probably almost since the beginning of when I started using WordPress.com.

    Okay, I disabled that setting and I made a new post & test post today, but the quadruple spacing glitch happened again.

    The only other thing that I can think to test is not using the Proofread Writing button and disabling these settings:

    "Proofreading

    Automatically proofread content when:

    a post or page is first published
    a post or page is updated

    English Options

    Enable proofreading for the following grammar and style rules when writing posts and pages:

    Bias Language
    Clichés
    Complex Phrases
    Diacritical Marks
    Double Negatives
    Hidden Verbs
    Jargon
    Passive Voice
    Phrases to Avoid
    Redundant Phrases

    Learn more about these options.

    Language

    The proofreader supports English, French, German, Portuguese, and Spanish. Your blog language value is the default proofreading language.

    Use automatically detected language to proofread posts and pages"

  12. That maybe, and disabling Zemanta to see what happens.

  13. Since I'm not able to reproduce this, if you are willing to continue testing with me, I would be very happy if you could go ahead and turn off one of those, try posting, and then turn off the other and try posting as well (you don't need to turn off both at once - it will be easier to see if one is causing the problem if you go one at a time). :)

    I really do appreciate it!

  14. Hello Zandyring,

    I had no idea that you had commented, for some strange reason sometimes I do not get email alerts when someone comments on a thread that I am subscribed to, I have no idea why this happens sometimes.

    I will try disabling those things one-at-a-time and I will let you know what happens.

  15. Under Dashboard | USers | Personal Settings | I disabled:

    "Proofreading

    Automatically proofread content when:

    a post or page is first published
    a post or page is updated"

  16. I forgot to add that did not work.

  17. Hi there - sorry that didn't work. To try to narrow down the culprit, would you mind trying these things:

    - turning off all your browser extensions
    - trying a different browser than the one you normally use
    - disabling Zemanta

    Do you compose directly in the WordPress editing window (I believe you said you do, but I just want to double-check) or are you pasting text from another program? If so, what program?

    Let me know how it goes.

  18. Hello,

    I tried those three things before without luck I think (I know I tried with extensions disabled), but I will try them again.

    Yes, I type directly, not copy & paste.

  19. Recently this problem has not been happening as much, under 25% of the time, and so testing this can take a long time since you do not know when it might happen; I tried your recommendations a few times and got tired (which has happened before), so I am not sure if it has stopped completely or not since it might only happen once every 10 posts but you never know.

    The problem is probably still there, but just happening less often.

  20. I will try to keep those changes that you recommended again for a week or so, and if the problem happens again I will report it here. ;)

  21. Sounds good - thanks for letting me know!

  22. No problem, thank you. :)

    It will be hard not using Zemanta for that long, but I can go back later & use it on those posts. ;)

  23. There are two ways to use Zemanta; enabling it on your blog's dashboard OR using it in your browser as an extension. Whichever you were using, try the other.

  24. Thank you Raincoaster, I did not know about that extension. :)

    I want to try it, but first I want to help troubleshoot what is causing the problem first; and then I could try that extension later I guess, and see if it also causes a problem. ;)

  25. I installed the Zemanta extension for Firefox, Raincoaster, while still using Internet Explorer to troubleshoot this problem; and I like how the Zemanta extension seems to be more updated than the one for WordPress.com with new features/look like images/thumbnails for Related Articles; maybe one day the WordPress.com version of Zemanta will be updated/kept updated and/or get that feature, hopefully.

    Thank you for the recommendation Raincoaster. :)

    Now I can use Zemanta, while still troubleshooting this issue in another browser. ;)

  26. Glad it helped! I'm a fan of Zemanta.

  27. Yep, it is one of my favorite parts of WordPress.com, if not my favorite, but now I know that it can be used on other services as well thanks to you & the Zemanta extension. :)

  28. Today I made a post in Internet Explorer again (which I am using to troubleshoot the problem), the post published with normal spacing, and then I used Firefox with the Zemanta extension to edit the post to add Zemanta suggestions; and after updating it the spacing quadrupled, and I could see this spacing glitch in Internet Explorer as well but it was caused when using Firefox & Zemanta (extension).

    This is only day two or so of testing, so maybe this will eventually happen in Internet Explorer as well, but right now maybe Zemanta (WordPress.com & extension) could be part of the problem; I/we will see eventually I guess.

Topic Closed

This topic has been closed to new replies.

About this Topic