Need help? Check out our Support site, then


WP breaking images by dynamically adding ?w=700 to URLs

  1. I had a draft post which was working fine yesterday, but when I posted it today none of the images were visible. All my images have a maximum width of 675px, but when I checked the source of the rendered page WP had on the fly added a width parameter as a query-string variable to the end of all the image source URLs (?w=700), which prevented them from being displayed. The extra query strings were not included in the source in edit view.

    I had to manually add ?w=675 to all the images to get them to display.

    The blog is: http://geotopoi.wordpress.com/

    and the post in question is: http://geotopoi.wordpress.com/2012/04/19/cwm-bychannantmor-copper-mine-2/

    this uses the theme: The Journalist v1.9

    My questions are:

    1) Why is this happening?

    2) How can it be prevented from happening in the future?

    Thanks for any help

    The blog I need help with is geotopoi.wordpress.com.

  2. @gastephen
    I have flagged this thread for a Staff respponse to your question.

  3. About how long ago did you publish it? We had an issue about 2 hours ago that I believe this was related to.

    It's all fixed now and shouldn't happen again.

  4. Thanks macmanx. It was posted April 19, 2012 at 7:25 pm UK time.

    I've just tried editing to remove my manually added ?w=675 override and previewing the result. The rendered page still has ?w=700 being added on the fly, e.g.:

    https://geotopoi.files.wordpress.com/2012/04/cwm-bychan-20120414-35-stopes.jpg?w=700

    but at least this seems to now display. So I guess, I'll keep my workaround edits in place for now.

    The source for this image in the post is:

    [caption id="attachment_4525" align="alignnone" width="675" caption="Stoping"]<img src="https://geotopoi.files.wordpress.com/2012/04/cwm-bychan-20120414-35-stopes.jpg" alt="" title="Cwm Bychan - 20120414 - 35 - stopes" width="675" height="450" class="size-full wp-image-4525" />[/caption]

    The original image is 675px wide and the above code was inserted by clicking the Add Media button in edit mode (which has explicitly set the width attribute correctly). So the ?w=700 getting tagged onto the image URL when the page is rendered can't be right, can it?

  5. Does anyone know if this issue was solved by WP? I'm having the exact same problem on my blog.
    In fact, I also have this problem in the multimedia library since thumbnails for new uploaded images are being displayed as broken links (although thumbnails do display correctly for older images).

  6. I this blog? http://2embedcom.wordpress.com/

    What exact code do you get for the thumbnails?

  7. Hi raincoaster,

    Yes, that's the blog (sorry, it's in Spanish).

    For instance, I have uploaded file 'smtp_configuration3.png' and the thumbnail doesn't display correctly because the URL links to https://2embedcom.files.wordpress.com/2012/05/smtp_configuration3.png?w=80 (if I remove the '?w=80' it displays correctly in the browser).
    Other thumbnails (from images uploaded few months ago) are being displayed correctly (like this one: https://2embedcom.files.wordpress.com/2012/02/2012-02-24_2embedcom_mwc.png?w=70).

  8. Sounds like staff introduced an issue with the theme when making it ready for the new ad program. I'll flag this for their attention.

  9. @rain:
    "Sounds like staff introduced an issue with the theme when making it ready for [whatever]".
    Arguably the current WP trademark...

  10. I hope they can solve it soon because I don't even able to insert images in my posts using the HTML editor. I try to specify the source of the image but then WP is adding the '?w=630' value at the end of the URL.

  11. Try using an offline editor, like a mobile app or Windows Live Writer. Those might work. I say MIGHT.

  12. I exported the images again and now could upload them successfully to the media library. In both cases they're PNG files, but in the first case they were bigger than 200KB and now they're around 20KB. Don't know if this may be the cause of the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic