Need help? Check out our Support site, then


WP publicizing my drafts to Twitter before I post/schedule them

  1. innataliesshoes
    Member

    I have linked my Twitter and Tumblr to the publicize feature on WordPress. Beginning today, any time I update or compose a

      draft
    , WordPress publicizes via my linked Twitter account. Obviously I want my posts to be publicized, but not my drafts! Is anyone having this issue? Does anyone know how to fix it?

    The blog I need help with is innataliesshoes.wordpress.com.

  2. I'm having the same issues.

    supahcute.com

  3. I have the same problem. It really is very bad -- I don't want drafts announced on twitter, what's the point of that?!

  4. tamarindandthyme
    Member

    I'm having this issue too!

  5. Really. It is so bad. Even if you desperately turn your blog to private (I had to do that for a few secs, in order to rescue something, and I hoped by turning it private I wouldn't accidentally post to twitter...) -- it still posts drafts to twitter.

    I'm not touching my wordpress account until this issue is solved...

  6. And the problem remains even after I have disconnected the blog from twitter...

  7. Actually, it is no longer possible to disconnect the blog from twitter. I clicked on disconnect, but it seems to either not work or revert back to being connected again automatically.

  8. innataliesshoes
    Member

    Yikes. This is not good. Hopefully they can fix this asap. I suppose all we can do it not start new posts until we're ready to sit down and write the whole thing.. Boo.

  9. I have same problem with not being able to disconnect from Twitter. Reverts back to being connected despite message in yellow box saying disconnect successful.

  10. innataliesshoes
    Member

    I meant to put that it is also happening on my Tumblr. I'm assuming it happens to any social media you have selected to publicize to. This blows.

  11. Our apologies for this — there was a bug for a few hours this morning that mean that all posts (even drafts and scheduled posts) were Publicized immediately. That should now be fixed, and you should be able to schedule a post or save a draft without it being Publicized until it passes the scheduled time for publishing.

    We're very sorry for the bug (this is part of some new upgrades coming to Publicize that will hopefully make up for it!)

  12. Does this mean that the posts -- the content I mean -- were also published on the blog? Or was it only a notification going out to, e g, twitter?

  13. @zooey: It was only a notification going out via Publicize. Unfortunately that would have linked people back to a "broken" link (since the post wasn't actually published yet), but they wouldn't have seen your unfinished post.

  14. Beau: thank you! I'm extremely relieved to hear that.

  15. same bug still going, here:
    - saving drafts makes them...publish
    - I still see "Twitter (2)" in the Publicize dialog
    - as an attempt, I've clicked disconnect LinkedIn. But I can't (I still see the green button: "connected"). As a result: I can't know, now, if Linkedin is connected or not.

  16. sorry to repeat, but the bug is still there (the blog is that on my link).

    I still see Twitter (2) and Linkedin (2) in the "publicize" line, even after I've tried to disconnect.

    And I can't save drafts, if I don't want them published...

  17. @fumettologico I've seen your post, and I see your post in the other thread as well. Please don't repost like this. We're looking into it.

  18. I tried save a draft of a test post just now and for me it did not post to Twitter.

    (But I also see the 'Twitter (2)' thingy and have no idea what it means. That troubles me much less than the involuntary 'publizicing', however.)

  19. @zooey, please try disconnecting from any services you're connected to and then reconnecting. We just put out a fix that will hopefully clear up and remaining weirdness like that.

  20. Beau -- that seems to have worked. Disconnected, despite this remained connected but now looks normal when looking on the 'Publish' thingy on a 'new post' page. Didn't need to reconnect, it seems.

    Thanks.

  21. I'm also having an issue w/Disconnecting...Prior to today, you had the option of re-posting to Tumblr or choosing not to for certain posts. However, right now, I'm seeing that ALL of my future drafts/scheduled posts are going to Tumblr, whether I uncheck the box or not...

    I've tried Disconnecting--but then that loses my 1-2 weekly posts to Tumblr. Is this a bug or a permanent change? Thanks!

  22. @meansheets can you please disconnect, reconnect, and then re-confirm if you're still having troubles?

    If you're still having issues, let us know exactly what's happening and we'll check it out. Cheers.

  23. Thanks, Beau...I tried the disconnect/reconnect. The problem I'm having is I have 5-10 drafts/posts scheduled in the next two weeks; however, I don't wish to have ALL of my weekly posts going to Tumblr (just, say, 1-2 a week).

    Anyway, so when I go to update my future post(s) and un-check the Tumblr box--the page updates w/the Tumblr box still checked...In other words, all of my upcoming posts are going to Tumblr unless I disconnect everything.

    Thanks again. Any suggestions would be greatly appreciated!

  24. @meansheets -- the temporary bug that caused posts to be Publicized when they were draft/scheduled is fixed now.

    Saving a post as Draft will ignore the Publicize checkbox and will not send it to Tumblr.

    When you actually Publish the post, if the box for Tumblr is checked, then it will be Publicized to Tumblr. If it's not checked, then it won't be.

    I think I see what you're saying now though -- when you uncheck the box, it's not saving the fact that it is unchecked. I'll look into getting that to "stick" (which it should).

  25. @meansheets: the issue with the checkbox re-checking itself should be fixed now. If it's not, please let me know.

  26. yep, works like a charm--thanks so much!

Topic Closed

This topic has been closed to new replies.

About this Topic