Need help? Check out our Support site, then


wrong page on web

  1. Hello Guys I cant delete a page ! On bringing my site up on a google search it brings a page up that I do not want, if I click home box it takes me to the page that I want to show, tis driving me mad trying to sort this

    The blog I need help with is bucksmobilelandrover.wordpress.com.

  2. You can exclude your blog from search engines by changing the option in your Privacy Settings: http://en.support.wordpress.com/settings/privacy-settings/

    Feel free to contact us if you have any other questions.

  3. Are you talking about some Google cached posts of your site?
    http://webcache.googleusercontent.com/search?q=cache:5W_amL5BFLwJ:bucksmobilelandrover.wordpress.com/+&cd=1&hl=en&ct=clnk&gl=us&client=firefox-a
    Otherwise your blog/site looks empty.

    If you add some more posts or pages, then those posts will disappear from Google searches. It's more important for a blogger to blog than to keep looking at google.

    Here are some tips about increasing your traffic:
    http://en.forums.wordpress.com/topic/how-can-i-make-my-wordpress-blog-more-popular?replies=2&message=closed#post-1091736

Topic Closed

This topic has been closed to new replies.

About this Topic