A non-existing 'Hello, world!' shows up in my RSS feed

  • Author
  • #877718


    I have linked my blog halifaxcharityknitters.wordpress.com to my profile on Ravelry.com and the oldest post is Hello, world! that shows the message that page can’t be found. I remember it was the first default post but I didn’t use it. It’s not listed in my posts, not showing up in the RSS feed, basically I can’t locate it.

    Is there anything that can be done?

    The blog I need help with is halifaxcharityknitters.wordpress.com.



    Since the post has already gone out on the feed, no, you can’t, but it won’t show up in future at all, so it’s not anything to worry about.


    Thank you,

    but why can’t I see it anywhere? I see a list of all posts when I click the RSS icon but it doesn’t show there. Also, how did it get there if it was never posted?

    This is a link, if it helps http://halifaxcharityknitters.wordpress.com/2012/02/09/hello-world/

    And if indeed there is nothing to be done, will it always show on my profile or as more feeds are added, it just won’t be visible?


    When you signed up and created your site, the hello world post was created by the wordpress software automatically so that you would not see a 404 error message on the main page of your site. At that moment, it showed up in your RSS feed. You then probably deleted it at posts > all posts in your dashboard, but as raincoaster says, it was already in your feed.

    When I look at your feed at http://halifaxcharityknitters.wordpress.com/feed/ I do not see the hello world post. Where are you looking to see it?

    Also, with your posts being HEAVY with images, I would suggest that you set your feed to “summary at settings > reading.

    And due to the fact that your theme uses infinite scrolling, I would also use the “read more” tag in any post you create so that most of the images are behind the read more tag. I waited 5 minutes for your site main page to load and then cancelled out and it was only about half way loaded.

    This is one of the main reasons (image heavy posts like yours) I argued for a way to turn off infinite scrolling because for people on marginal or slow internet connections, it drives people away. They simply will not wait for everything to load. Before infinite scrolling hit your theme, you could set the number of posts that you wanted to show on your site main page, but you cannot now.

    Thanks Matt and AutoMATTic.



    Since they are using MistyLook, which does not have footer widget areas, they would have to switch themes to a theme that does have footer widgets.



    Thank you, it was informative. I see the post in question on my Ravelry profile, it’s a network for crafters. I checked yesterday that the feed there shows last 25 entries, so eventually it will disappear from sight.

    I was worried about infinite scrolling too. I am new to this and I didn’t realize there was no option when I chose the theme. I would prefer to have one post showing at a time with ‘newer posts — older posts’ links in the footer.

    Can anyone suggest similar theme that have such option or let me know how to check it?

    Thank you guys, you are very helpful.



    You can do that on literally ANY theme, simply by going to Settings->Reading and choosing “blog page shows at most…1…post(s).”



    Well, any theme except one with infinite scroll AND no footer widget area. So pretty much any theme except the one you have right now. You’ll probably want one with a large header area and a tabbed header, as those are the things that my students always like about MistyLook.


    Thanks. Do you mind if I ask a few more questions before I go and break something experimenting?

    I am looking at Vigilance but it seems that the header (name) and the header image appear at the same spot. I could add the name of the blog to the image but don’t I have to have a name for the blog, too? Confused. Looking at a sample blog http://crabbyoldfart.wordpress.com/ and I see that there is no ‘name’ displayed, just text as a part of the image. I am thinking about searching here…

    About scrolling – if I don’t see it in theme details, it’s not there, and I can specify the number of posts showing, correct? (I was doing it with my previous theme and was wondering why it didn’t work) :)



    Oh, CrabbyOldFart is awesome.

    When you put in the title of the blog on the header, you can select to make it visible to search engines but not to regular readers.

    Infinite scrolling is coming sooner or later to all themes, but you can at least disable it in footer-widget themes. Pick one with a footer; you should be able to filter the theme search for that.


    Is that how I make it invisible? http://en.support.wordpress.com/themes/custom-header-image/

    And with that, should I put ‘no’ or choose a certain colour?

    Yep, he is. I wasn’t going to read anyone’s blog for before fixing mine, but yeah, didn’t work… :)



    Yes, on the Header part of the dashboard there’s a tickbox to make the writing visible or not. Don’t choose a colour; it will ALWAYS show up.



    I spent lots of time today ‘trying on’ different themes. Is it correct that there are only 27 themes with a footer or it means that only these 27 added it as a tag?

    Also, if I apply a new theme and it doesn’t have a feature that my blog currently has (say, a cloud tag in twenty-ten), does it mean that it is not available?



    I don’t know for sure, but that sounds right. Footer widgets are not common because most people don’t see them.

    Cloud tag isn’t a feature: it’s just a widget. You can add that to any widgety theme, meaning any except Monotone and Duotone.


    Wait, did it work? Can someone check? I did change the theme to twenty eveven but was overwhelmed with too many changes that needed to be done. So I reverted it back to Misty Look. And now I see one post per and links to older – newer posts.

    Thanks, raincoaster.

    And also thanks, timethief. I didn’t reply to your post but I read numerous posts on your blog and found them very useful.

    If I understand it correctly, this piece of advise helped

    If you do not want to switch themes then first do what’s in (a) and then switch back to the original theme without footer widgets that you were using.

    It sort of didn’t make sense first (cause there were two themes involved) but those were the steps that I took, albeit unintentionally.

The topic ‘A non-existing 'Hello, world!' shows up in my RSS feed’ is closed to new replies.