A possible reason Akismet may be filtering comments as spam?

  • Author
  • #1356932

    Since yesterday sometime, about ten or twelve of my comments on others’ sites have been filtered out the first time I try to put them through. It happens like this: a nearly blank page comes on with the words “Sorry, this comment cannot be posted.” I don’t know for sure that this is Akismet’s doing, but when I saw the sticky post at the top of this page, I thought it might be and wrote them. It has occurred to me that if people use figurative (poetic, non-literal) language such as metaphors and similes in writing, Akismet may be filtering it out as literal spam. For example, I said to someone in a comment that “I have trouble sometimes changing gears,” meaning “trouble going rapidly from one activity to another.” In this case, I lost the comment to the “sorry, this comment cannot be posted” warning. But as had happened before, when I typed in the message a second time (and rephrased it in this case, though I left it the same in others), it was accepted. Still, I seriously hope that figurative language, part of the wealth of our spoken and written heritage, will not be off-limits due to some malfunction with the Akismet filter. I did express this notion to them in the supposition that it might help. I do know that with some remarks (when I got over my frustration with having to try to remember exactly what I had said before) it was possible just to retype them to get the filter to accept them.



    Are you using Talk Talk?


    I am having the same problem as an administrator and so are some of my bloggers and it has been going on for over 24 hours. I am getting tired of having my comments go off into oblivion when the “Sorry, this comment cannot be posted” appears. On another thread referencing this problem the following input was given as to why this was occurring. “We’re implementing some extra security checks on comments, but that broke commenting for some users. We’ve rolled back the checks for now, while we work around these problems.”

    Well apparently this roll back has not occurred. Something needs to be done to stop this problem and brought to the attention of the technicians at WP. Becoming extremely frustrating.


    No, as far as I know I’m not using Talk Talk, to answer TimeThief’s question. I’m just using my own site and commenting on other people’s sites the way I usually do. Only if Talk Talk is something that was enabled from the very beginning automatically on WordPress.com could I be using it, so I guess I’m not. No one’s ever asked me to, anyway. What is it, and what difference would this make? Thanks for a response.




    Hi again. I started out by reading the sticky post at the head of the forum the first thing, which is why I contacted Akismet as requested. But I don’t think the “Sorry, this comment can not be posted” which has occurred when I’m commenting on others’ sites has anything to do with your suggestion which proved fruitful on your second listed link above (the one which has to do with Talk Talk), because not only am I using Internet Explorer as others who made the “13 replies” were not apparently doing, but I have been using https on my site for months and months now, ever since the last time there was some sort of general problem, and it’s been working fine. And also, I’ve had no other problems of any sort on my own site such as were listed in those 13 replies, only this recent first-time refusal to post on some sites (and as I’ve said, the remark I try to post, in original or altered wording, is successfully posted the second time I try it each time). Nor have I received any of the other warnings you have listed under “replies=13” above. Thanks for letting me know about it however. If anything else occurs to you before Akismet does their thing, whatever it is, I would appreciate it if you could let me know. And thanks for devoting so much time and attention to the problem already.



    This thread was previously tagged for Staff. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.



    Hi shadowoperator, thank you for reporting this issue. Are you still having trouble with it?

    If so, can you please describe exactly what steps you take when it happens, so our developers can reproduce it? Please let us know whether you are already logged in, what URL you start on, what you click on, etc. Thanks!


    Hi. Yes, thank you for asking. I am still having trouble with it. I’m not sure what you mean by “what URL you start on,” but I’ll describe what happens. What happens is that I am answering and viewing comments through my e-mail ((email redacted)). So far, I haven’t had any troubles of this sort answering comments to my own site. The URL of my website is https://creativeshadows.wordpress.com, if that’s what you mean. But when I click on the “reply” button on the comment for the first time, it takes me to the other person’s site to make the comment. These days (with the error message appearing) I dutifully word my message and leave a comment, click, and wait for it to tell me “sorry, this comment cannot be posted.” Once it does, I cancel my response (using the little box at the very, very top of my screen which shows the title of the e-mail or note, I’m not sure what it’s called, it’s not my browser, but it’s on that line and I just use the “x” by the words to cancel), re-enter the person’s site, and do it again. The second time, it works, whether I re-phrase or not. One thing I have noticed that’s different, though, is that the first time when I type, the “notify me of follow-up comments” and “notify me of new posts” messages are both just below where I make the comment (and I always check them, even though I’m already subscribed to the sites I read), whereas when I go in the second time, only the “notify me of follow-up comments” line is below where I make the comment. I hope this helps. I’m sorry I can’t be more specific, I don’t have all the required “computer-ese” to use the right words for it.



    Thank you for these details! I have passed this information on to our developers, who are looking into the issue. I will keep you posted about what they find out!



    Hi shadowoperator, our developers have deployed a bug fix that should resolve this commenting issue. Can you let me know if it’s fixed for you?

    If it isn’t fixed, we have one more question about your process for leaving comments. When you first click on the “reply” button to leave your comment, are you already logged in to your account at WordPress.com? If not, can you describe the steps you take to log in? Thanks!


    Sorry to keep you waiting–I had already read all my e-mailed-in comments and had to wait for another one to appear to try the “experiment.” I don’t think when I first click on the “reply” button to leave my comment that I am logged in to my WordPress.com account, because though it is the WordPress.com form for sending e-mail comments to my e-mail address, until I ACTUALLY click on the reply button on the WordPress e-mail page, the title of the post or comment doesn’t appear in the tiny right-hand box at the top of page in the browser line (a locale I don’t know what to call, but I mentioned it before). When I click on the reply button, I think it performs a sort of half-and-half login between my e-mail site and WordPress.com, because then it calls up the picture of the post/comment that I want to respond to in the page on someone else’s site. I type the reply. BUT THEN I actually hit the WP ICON on the bottom of the form (I think there’s also a twitter and another icon there) to formally log in. I log in. I click on “notify me of follow-up comments” and “notify me of new posts” then on “post comment.” After it fails, I go back and do it again after cancelling the remark with the “x” at the right-hand side of the box on the right-hand side of the browser line at top of page. And no, it still didn’t work today. The only thing I can think of which is possibly an added kink in the situation is that I have Norton security Identity Safe Cards and Logins and Login Assistant on all my logins so that I can type one password and get to any login on my computer and still be safe. But since I only use this just after I hit the WordPress.com logo (the Norton password prompt appears, I fill it in, then the WordPress.com password prompt appears and I hit the button for it), this shouldn’t be a problem. In any case, it keeps my computer and all my sites safe with the rest of my Norton paraphenalia, and I would be hard pressed to function without it. I hope this helps.


    Hi, it’s me again. Sorry to bother you, but just after I wrote the above response and before you contacted me again, I got the comments to work twice, once a comment in response to a comment, and once a comment in response to a post. I don’t know if this means it’s entirely fixed, but things are looking up! Good job and good luck with making it permanent!



    Thanks for all of the details about logging in and for letting me know that it’s working for you now!

    If the problem does pop up again, I have another little question about your login process. After you click the WordPress icon and log in, do you see a sentence under the comment box that says, “You are commenting using your WordPress.com account”?

    Hopefully it will keep working and that won’t be an issue. :)


    Yes, at least some of the time (I can’t be sure about all of the time yet, since I wasn’t looking for it) the comment “You are commenting using your WordPress.com account” is there. Let’s all hope for the best, you guys have been working hard on it!


    Hi, Rachelmcr. I was contacted by Akismet yesterday, and I just got finished telling them that this problem had been resolved by WordPress.com, when (today, Friday July 26th) the problem popped up again on one of the sites, and I used my usual second attempt system to post a comment. The first site I tried today didn’t have this problem, so it’s not all sites, but the second site I posted a comment to today did(and the forum rules below prohibit mention of which particular site it was, but I’ll tell you if you want to contact me some other way, perhaps at my e-mail address since you have it on file there, or else give me permission to mention the site). I’ve been going along quite happily since I told you just above that the problem was solved, but I don’t think (I can’t be sure) that the site with the problem said “you are commenting using your WordPress.com account.” You were so helpful before, a real wizard. Please advise. creativeshadows.wordpress.com



    Thanks for the update — I’m sorry to hear that this problem is popping up again! I let our team know and they will look into this issue for you.

    Can you let me know what site you had trouble commenting on? (You can post the link as a reply here.) Were you already logged in to your account when it happened, or did you log in with the WordPress icon in the comment form again? Thanks! If the team has any other follow-up questions for you, I will be back in touch.


    Hi. I forum posted as soon as I had trouble yesterday, but because it was my first comment of the day, I didn’t realize that in all likelihood it’s possibly only that or maybe a few sites that I would still be having trouble with (that is, during the rest of the day, I posted comments without any problem to other sites, and without having to do it twice). The site is http://truthandcake.com/ and the only thing I notice different about it is that when you’ve almost completed the logging in process and are hovering over the “post comment” button with your cursor, there appears a little balloon that says “really simple syndication,” which disappears once you post. That’s the only site I’ve noticed that on. As to whether I was already logged in when this happened, it’s as before. I logged in with the WordPress.com icon, but as always, it gives me the remark “You are commenting with your WordPress.com account” before I actually hit the final button. I hope this helps. Kudos on all your hard work.



    Thanks for that info! Our team is looking into it to see if we can get this issue resolved once and for all. :)

The topic ‘A possible reason Akismet may be filtering comments as spam?’ is closed to new replies.