How can I activate Jetpack if I see an msg saying it's not publicly accessible?

  • Author
    Posts
  • #640141

    I am trying to activate Jetpack on my blog. When I try to connect it to wordpress I get an error that my website needs to be publicly accessible. Can anyone help me with this?
    Blog url: http://genxdad.com

    #640349

    hanni
    Member

    My apologies! Can we get a bit more information about your environment? Which other plugins are you running?

    Also, can you try running curl -i -L --data 'test' 'https://jetpack.wordpress.com/jetpack.register/1' for us?

    #640353

    I see that you are running Microsoft-IIS/6.0. Could you post an exact copy of the error message please? It would also help to know if you can find any jetpack-related errors in your server error log during the times you try to click the Connect to WordPress.com button. You should be able to get access to the server error logs through your host. If your host runs cpanel, most have an option for error logs on the main page.

    #640365

    Thank you all so much for the replies. Let me see what questions I can answer right now …

    Exact error message is:
    Your website needs to be publicly accessible to use Jetpack: site_inaccessible

    Error Details: The Jetpack server was unable to communicate with your site [IXR -32300].

     I am looking for log access now.

    Hanni – where would I run the code you posted? This is a hosted server I am not sure I can pull up a command line window if that is needed.

    Thanks again and sorry for the lack of knowledge here.

    #640368

    You would need to have command line access to run the command Hanni mentioned.

    Do you access admin over HTTPS or HTTP?

    In Settings → General, what are the settings for “WordPress address (URL)” and “Site address (URL)”?

    #640375

    I access via HTTP.

    The wordpress address and site URL are both specified as http://genxdad.com

    #640385

    As for plugins I am running Akismet and Twitter Goodies. Both seem to be functioning well.

    #640398

    macmanx
    Staff

    Would you please try completely uninstalling the plugin?

    To do this, you would need to both deactivate and delete it from the Plugins section of your Dashboard.

    #640410

    Problem solved …

    While trying to activate a theme it gave me an error that my php install was too old, a later version 4. I contacted my hosting tech support and they. Upgraded me to version 5. The theme then activated so I gave Jetpack another try and it works great!

    #640414

    Thanks for the follow-up note! Much appreciated.

The topic ‘How can I activate Jetpack if I see an msg saying it's not publicly accessible?’ is closed to new replies.