Need help? Check out our Support site, then

Add hyperlink erases entire post

  1. Whenever I attempt to edit my work related blog from my office, I am unable to add a hyperlink. I can select text, hit the 'Add/Edit link' button, type in an address and then hit the final 'Add Link' button. However, after doing so, the entire post is erased and no hyperlink is added.

    Could this be related to our office firewall? We have a baracuda firewall that we have to route through in another state. I'm wondering if it can be blocking WordPress functions for some reason. Also, the "add media" button doesn't work at all.

    This has been happening for a very long time, so I've been having to edit my blog from home. Any ideas?

    I'm on Windows 7 64 bit, tried both Firefox and Internet explorer with the same result.

    The blog I need help with is

  2. These are the troubleshooting steps we take whenever any issues like this arise:
    clearing your browser cache and cookies >
    using the browser with all extensions or add-ons disabled
    updating the browser to the latest stable version (not a buggy BETA browser version)
    confirming third party cookies is enabled
    confirming JavaScript is enabled
    confirming Flash is updated and if required installing the latest version of Flash
    resetting your router and modem and rebooting your computer
    then logging in using the secure https:// log-in see
    trying another browser

    If those do not work for you then we need to know
    (1) how you are connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.

    (2) exactly which browser and version of it are you using. If you don’t know click here to find out >

  3. I also note that the free hosted blog linked to your username is devoid of any blogger created content. Are you sure you are posting to the correct support forum? We provide support here only for free hosted blogs. All others must post to
    Please read > vs

  4. Yep. We run a few blogs here. I maintain all of them. These are all hosted sites, we just paid to have the domain names with the blogs.

    None of these work, however. I've already tried everything you mentioned, even starting with a fresh Windows Installation. This is why I'm wondering if it's firewall related. I connect to the internet through our corporate network which is routed through our corporate HQ in a neighboring state. At one point, WordPress was blocked, but I had them unblock it. I'm still thinking that maybe some Javascript for the button functions is being run from a different wordpress domain that is blocked. I've run out of ideas at this point.

  5. I'm flagging this thread for a Staff response.

  6. Well this is interesting. I just took a shot in the dark, and if I connect via HTTPS instead of HTTP, I am able to edit the hyperlinks and add media. However, Internet Explorer keeps switching back to HTTP, which is annoying, and I'm stuck with IE.

    It looks like unencrypted traffic is the culprit, but why would that be?

  7. This definitely sounds like the firewall acting up.

    When you connect via HTTPS, there's a slightly different route your connecting takes.

    You can set HTTPS permanently by checking "Always use HTTPS when visiting administration pages" at Users -> Personal Settings in your Dashboard.

  8. Thank you, that's what I'll do then. I suppose that solves the issue. I have certainly have no problem with using HTTPS (in fact, I prefer it).

  9. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic