Add media button not working

  • Author
  • #956307


    I just joined today and was working on a post and the add media and the add poll button both do not work. I have refreshed my browser and cleared out the history and it still doesn’t work. It seems to be one of those bugs where it works sometimes and other times it won’t.
    Blog url:

    The blog I need help with is



    Sorry this is happening to you on your first day! I’m having the same problem, as are others. I’ve not seen this glitch before on WordPress.


    I am having the same problem! The add media button was working fine earlier today, but now not working at all. This must be a system wide problem? Please post if you hear of any solutions!



    I’ve been experiencing problems for the past 2 days at WordPress first I see my homepage get buggy with nothing showing up under the tabs yesterday and now I’m having the same problem as you guys with the Add media button today. Tried refreshing and even tried it on a different web browser but the results are still the same :(
    Currently waiting for the bugs get fixed……..I’m having the same problem now


    The same is happening to me. I have tried clearing my cache and browsing history with no luck. The “copy a post” and Help links are also not working for me…



    There are some very unusual issues going around right now. I suggest waiting it out while staff are working on the issues.


    I’m having the same problem! I only started on WordPress a couple of weeks ago, went on holidays, came back today and purchased a new theme (Portfolio) – I thought that must have been the problem. I tried closing all other tabs, then I moved from Safari to Firefox… nothing. I have very little to show for my blog! Sort of nice to know others are having the same problem. Will await.


    me, too- hoping a solution will be posted here…


    Having the exact same problem as everyone else. Very Strange


    Having the exact same problem as everyone else. Very Strange


    WordPress seems to be a little buggy today, and the staff will be fixing it soon.
    Please view for more information.


    Yay, the problem no longer seems to be a problem for me…



    It is probably one of those things that sometimes doesn’t work now and then. It began to work for me again the next day after the problem. When encountering this problem you can try this, once you’re on your blog’s page and you click on the “new post” button, a drop down will come and you can post there since the “insert photo” button worked fine when the “add media” button in the editing page didn’t. It is the same setup somewhere else on the site, but I don’t know how to explain getting there. Hopefully, this may help someone out!

The topic ‘Add media button not working’ is closed to new replies.