Need help? Check out our Support site, then

Add Media not working

  1. Add media will not work for any of my pages or posts, how do I fix this ? Nothing happens at all when you click the ADD MEDIA icon. Worked last week, just stopped working for me. Please help.

    The blog I need help with is

  2. In order to help you we need to know your specific computing environment details. Please work through what follows and report back.

    1. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode.

    3. If you are running one of the browsers and versions listed at

    (a) Try clearing your browser’s cache

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS:

    Add both * and * to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary
    (c) And what any error reports you receive state.

  3. I use Internet Explorer. I have never upgraded anything in last year and have never had any problem until the other day when ADD MEDIA just stopped working for any new posts or pages. I did changebut I tried changing to my old theme and other themes and still the ADD MEDIA didn't work.

    Compatability mode is disabled.

    Guess I gotta try all that other stuff when I get time. Kinda a big pain.

  4. (a) Exactly what kind of device you are using to connect to the internet and to
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary
    (c) And what any error reports you receive state.

  5. parlorofhorror

    My add media stopped working in my add post page along with adding a hyperlink, and adding tags. Its like the whole page suddenly doesn't work. I am using EI 9. it was working fine until you changed the reader now nothing on the add posts page seems to work. There are no error reports, I click the add media and nothing happens. However, I can still upload media from the left side toolbar but can't place it in the post. If I try to insert a hyperlink, it erases the whole post. If I type in tags and click add tags nothing happens. Please help, I have some time sensitive material I want to post.

  6. I am using EI 9

    Thanks for that information for Staff.

  7. I'm having the same problem. I first noticed it yesterday.

    I use IE10, and have had no problems until yesterday. None of the buttons to Add Media or Add Link seem to work.

  8. This is to let you know that this thread and all threads like it are tagged for Staff. Note that other switched to using Firefox and that resolved their issue.

  9. You need to update to IE11. It worked for me.

  10. canadianveggie

    My mother is having the same problem on her blog - the editor started having issues today. I'm trying to debug the issue by email, but I'm not getting anywhere. I can edit her site fine in Firefox. I think she's using IE. Not sure what version. Let me know if you find a solution.

    Here's what she sent me:

    Tried rebooting my computer, still no luck.
    My toolbar about the post is not the same as previous. All the buttons are missing (eg Bold and link buttons). I can do Bolding in the visual tab but not text tab.
    When I press the add media button, nothing happens.

  11. You need to get IE11. Make sure you reboot after you've updated.

  12. Did I not already clearly state this above?
    1. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

  13. Hello all. I am the one who started this discussion. I checked the browser as suggested by TimeThief above and found it needed to upgraded. I upgraded it to IE 11 and all works well now. Good luck everyone. Some days I hate technology! Thanks, TimeThief for your help and patience.

  14. parlorofhorror

    I have windows vista and it says IE9 is the latest update - which windows do I have to upgrade to to get IE 11? (If you don't mind my asking)

  15. canadianveggie

    So, IE 11 has been out for only 3 weeks and has already dropped support for IE 10?

  16. @parlorofhorror
    You could switch to Firefox

    I do not see Staff saying that here or in any other thread.

  17. I just switched to Firefox and it finally worked. Not sure why it won't work anymore for Internet Explorer (the version I have). Good waste of a few hrs trying to figure it out.

  18. canadianveggie

    @timethief I don't use IE, but I'm glad they're not dropping support. Not everyone can easily upgrade to the latest version. Sounds like this is likely just a bug. Hopefully it is fixed soon.

  19. My "Add Media" has suddenly quit working. What's happening?

  20. Howdy,

    We're working an issue that's impacting folks using Internet Explorer 9.0. While we're getting this fixed, would it be possible to either upgrade to IE 10 or to use Firefox or Chrome?

    We'll post an update at

    Thanks for your patience!

  21. parlorofhorror

    Everything is fixed now, thanks so much for your attention to this matter :) I'm still running IE9 and the 'add post' page is working fine.

  22. Thanks for fixing this. I feared that all of your smart software people would have been scooped up by the government to fix the Obamacare website.

  23. tailsofafostermom

    I have IE 11 and have also tried Firefox, am having the same problem. I click on the "Add media" button and nothing happens. There is no error. I can add media to the library. However when in a post & trying to add media, I am not able to do so. PLEASE help!

  24. Hi @tailsofafostermom,

    Could you open up a new thread so we can work on this in more detail without pinging the other folks who have already posted in this thread.

    If something is up with IE 11 and Firefox, then it is most likely a connection issue and not the same cause as what led to this thread.


  25. For those using Mozilla Firefox 24 and 25 -

    I finally figured out why I could not "add media" or click on various blog features with no response.

    This is what I discovered......

    I went to IE8 and the blog worked perfectly.

    I recently updated to Firefox 25, but the WP features had stopped working in FF23.

    I then went to FF extensions and addons and began disabling everything then restarted FF and my WP blog worked perfectly.

    I then added on only the features that I needed in FF and restarted the browser only to discover that my WP features were again not working.

    Only by dumb luck did I discover that it was GHOSTERY that was blocking the areas of WP were you can add media, polls, look at stats, etc.

    I went into Ghostery and you have to disable "wordpress stats" and "gravatar" then reload the page and walaaa everything worked perfectly. And no other FF addons or extensions were effecting WordPress other than Ghostery.

Topic Closed

This topic has been closed to new replies.

About this Topic