Adding images locks up after upload reaches 100%

  • Author
  • #1753847


    When I try to upload an image, it appears to almost complete the process, and then fails. This is happening with even files under 10 KB, so it’s not a large file problem, and my interaction with the rest of the site is working fine, so it’s not an internet connection issue.

    If I try via the “Upload New Media” page, using the multi-file uploader, the image’s progress bar shows up and goes to 100% within a fraction of a second, and then stays at 100% rather than completing (it never shows up in the media library). If I switch to the browser uploader, when I select the file and click “Upload”, it starts loading media-new.php, thinks about it for approximately 5 seconds, and then the page loading “completes” with nothing but a blank white screen.

    If I click the “Add Media” button when editing a post, and then choose and upload a file, the progress bar fills up almost instantaneously, and then sits at a full progress bar for about 15 seconds, after which it gives an error: “An error occurred in the upload. Please try again later.”

    This has been a sporadically recurring problem, but in the past few days I haven’t been able to get virtually anything at all through. A 7 kb PNG worked, but a JPG of the same size did not. It fails reliably in the evening, but sometimes works mid-day and often works late at night, which makes me think it’s a load issue on the server end.

    This is really hampering our blog usage.

    The blog I need help with is



    There’s no known issue I am aware of.

    In order to help you we need to know your specific computing environment details. Please work through what follows and report back.

    1. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode.

    3. If you are running one of the browsers and versions listed at

    (a) Try clearing your browser’s cache

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS:

    Add both * and * to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

    4. You can use this link to see if your flash is up to date. If it’s not then go to and download and install the latest version of flash.

    5. Try using another browser.

    6. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary
    (c) Exactly what you experience including what any error reports you receive state.



    Edited to add: After approximately 20 tries, doing absolutely nothing different, I got a JPEG image to process successfully. Then I immediately tried it again and it failed again.



    6a) iMac 2.9 gHz Intel Core i5, OSX 10.9.2
    b) Safari 7.0.3
    c) As described in original post.



    Please go through the checklist item by item that I posted above. I’ll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.



    Oops! We were typing simultaneously. Please be patient while waiting for Staff help.



    Hi there,

    If you tried all of @timethief‘s suggestions and they do not solve the problem, can you also try using a different browser: Chrome or Firefox?

    Also, can I get a little bit more information? Does this problem occur for just that specific image or any image? I see that you were first having a problem with a JPEG file and then it worked, and maybe stopped after. So, I’d like to see if it’s a specific image file, a file type or just all images in general.

    Let me know and I’d be happy to take a further look!

The topic ‘Adding images locks up after upload reaches 100%’ is closed to new replies.