Adding Links & have WP url added

  • Author
    Posts
  • #784719

    digireado
    Member

    Hi, I have a drafted post and I have a problem with some (not all) of the links/hyperlinks within it. I added links through the visual editor in the normal way that has always worked however most when tested had the prefix of my blog added (ie turn out when clicked as http://digireado.wordpress.com/www.external link, coming up as a 404.

    After a search I’ve tried adding the links through the HTML editor by first removing link in visual, then highlighting word in the HTML, clicking ‘link’ and adding that way. Strangely, it seems I’ve fixed some but not all. At this stage my sanity is feeling a little tested as I’ve posted close to 40 times and haven’t run into this problem.

    Any suggestions?

    The blog I need help with is digireado.wordpress.com.

    #784820

    raincoaster
    Member

    Make sure when you post that you remove the http from the links before pasting in the link itself. That can cause this problem, as can linking to affiliate sites, which is generally banned here.

    Can you paste in this thread one to three of the links you’re trying to add to your blog?

    #784961

    digireado
    Member

    (sorry for delayed reply, I thought I’d posted from my iPad but not showing up)

    Firstly, thanks for your quick reply. I’ve been copy/pasting the url from the live external site into the blog. I’ve tried inserting via the visual editor and following some instructions I found via the HTML editor.

    The link is a general website not an affiliate site.

    One I’m having a problem with is

    http://www.ozyroadtripper.com.au

    Thanks for taking the time to reply!

    #784962

    raincoaster
    Member

    That is not a WordPress.COM blog but a WordPress.ORG blog, and we won’t be able to help you here; you’ll have to go over there for help.

    #784963

    What you are going to have to do is to edit the links. Not sure why the wordpress part is getting added at the front end of the link, but I’ve seen that before (not for a long time though). It might have something to do with the touch interface.

    #784964

    digireado
    Member

    Thanks for reply raincoaster.. Which one is a wordpress.org blog? mine is on wordpress.com and the url I mentioned is merely an external link (as far as I know!)

    Would you be kind enough to explain a bit more and then I’ll follow up.

    #784965

    digireado
    Member

    Thanks for reply thesacredpath. I’ve checked the links in the html editor and that’s the strange part – the urls do NOT have the wordpress bit at the front (ie they show http://www.ozyroadtripper.com.au not http://digireado.wordpress.com/www.externalinkexample.com)

    I’ve tried editing them SEVERAL times without success! It’s odd when you do the same thing as you’ve always done and then it’s not working the same way?!

    #784966

    raincoaster
    Member

    Ah, I get it now; you’re trying to link to that blog. I thought you meant that was your blog.

    I don’t see any errors in your existing posts; could you make a test Page with some of the links you’re having difficulty with? Then give us the link and we can see it in action.

    #784967

    digireado
    Member

    Thanks for reply. Yes, on my blog (digireado.wordpress.com) I’m trying to link to the website ozyroadtripper.

    I think I’ve done what is needed – ie created a private page? The link is here

    The problems I’m having are in the first para the website listed in last line OzyRoadTripper

    the last para all links.

    I’ve just copy/pasted out of my draft post so of course it doesn’t make any sense at all!

    Is this what you suggested?

    Anna

    #784968

    raincoaster
    Member

    I’m afraid we volunteers can’t see private pages. You could make it a sub-page of an existing page and just not link it anywhere and that way we could look at it.

    #784969

    digireado
    Member

    oh, ok. I don’t actually know how to do that… Sorry.

    #784970

    raincoaster
    Member

    To make a sub-page, read through the instructions on here:

    http://en.support.wordpress.com/pages/

    #784971

    digireado
    Member

    This is excellent as I’m learning new things along the way, thank you!

    Try this: http://digireado.wordpress.com/?page_id=882&preview=true

    As mentioned above

    the problems I’m having are in the first para the website listed in last line OzyRoadTripper

    the last para all links.

    #784972

    raincoaster
    Member

    Unfortunately, unless the post is published volunteers can’t see it. Staff can, however, so I will flag this for their attention. I’ve seen a similar error in the forums here from a completely different user, so we should get on this ASAP.

    #784973

    digireado
    Member

    Thanks you, but please look at this page (I was crazy and sent you the preview page before I’d published it). Apologies, I’m feeling my way through this and appreciate your help.

    http://digireado.wordpress.com/digital-acronyms/link-issues/

    #784974

    raincoaster
    Member

    No worries, it’s a complex issue.

    You can set the page to Private now, but keep it so staff can look at it. They can see Private pages.

    I’m thinking the issue must be that the site you’re linking to (and their Twitter) is on some kind of hot list at WP.com and that’s why the links are messing up. Only staff can resolve an issue like that, and I’ve already flagged them for you. Wait and see what they add to this thread.

    #784975

    digireado
    Member

    Thanks for the advice. I think it’s very unlikely that the site would be on a hot list as it’s a very new site only sent live very recently and since I know the writer concerned… however, I look forward to hearing what the potential problem comes down to!

    thanks again for all the time you have put into responding. Much appreciated.

    #784976

    raincoaster
    Member

    You’re welcome.

    Sometimes things get flagged for no reason, by accident, or for reasons that later turn out to be mistakes. It happens to all of us sooner or later, so this is a good opportunity to make sure staff aren’t flagging something they shouldn’t be. The site looks fine to me, but I’m not staff.

    #784977

    macmanx
    Staff

    You aren’t inserting the links correctly, you’re leaving off the preceding http://

    Without that, your browser thinks that the link is relative to the page it’s viewing, so www. facebook .com/OzyRoadTripper becomes http://digireado.wordpress.com/digital-acronyms/link-issues/www.facebook.com/OzyRoadTripper

    Try linking to http://www.facebook.com/OzyRoadTripper instead.

    #784979

    raincoaster
    Member

    Ah, thanks! I originally thought it was the opposite: putting in an extra http!

The topic ‘Adding Links & have WP url added’ is closed to new replies.