adding pages to menu

  • Author
  • #576612

    Another question – sorry!

    I wrote a page and when I previewed it, it was in the place of my blog, although I could click the blog tab and the posts appeared, but then the page was gone. Do I need to publish the page before directing where it goes? And how do I get it in the correct place? The WordPress help had a neat video, but it showed a place on the right where you could put it on a parent or child page – this was in “Attributes” right above “order”, Where I was composing the text of my page, there was only “order” listed under “Attributes”. Does the main/no parent vs whatever else only appear after publishing?

    This is just one more place where Support doesn’t seem to have complete info. It’s very frustrating.

    The blog I need help with is


    I would also like to know the answer to this. WordPress is very frustrating to navigate sometimes.


    Melinda, I think I figured it out! Yesterday I was afraid to publish the page without knowing where it would end up. But since we didn’t get any other replies, I decided to risk some experimentation tonight.

    Go to the page tab at the far left of the dashboard, click “add new”. Write your text and after any editing and previews, click “publish” over on the right.

    Then go to the appearances tab near the bottom far left, click on menus. In the left column of the menus section there is a “pages” box (3rd from top). The title of the page should be listed. Check the box, click “add to menu”. It will appear at the bottom of the menu listings. You can move it up and/or indent it to be a section under one of your menu tabs.

    Hope this makes sense and works as well for you as it did for me.



    Pages and Posts are entirely different things. You want to make sure you know the difference, because they behave differently.


    This will explain the differences between pages and posts.


    highdesertreferendum – Thank you! I will try that… I had created a page with links to my articles written on HubPages, but the page wouldn’t appear with the other pages…I just decided to Blogroll the links on the “home” page…but maybe I will end up with an article page if it works.


    Thanks, raincaoster & sacredpath, I appreciate your support. I think I’ve got things straight now. Worked on my site last night and got everything in order.

    Melinda, hope you figure out that article page. Checked your site – looks good, lots of content. We use the same theme.

    The only thing I still need to know is how to mark this topic as resolved. Changed it last time, but it changed back.



    I understand how to set up the page, where to go, etc. I did that and I still have no page showing at the top menu. I’m not having issues with widgets, but in Choco, I cannot get a new page to show. I published it, so that’s not it. I want a “Home” “About” and “Not About” for pages. Please try to help me again. Thanks.



    The blog linked to your username is not wearing the Choco theme. Please post a link to the blog in question starting with http://

    To create a custom menu, give it a name above and click Create Menu. Then choose items like pages, categories or custom links from the left column to add to this menu.

    After you have added your items, drag and drop to put them in the order you want. You can also click each item to reveal additional configuration options.

    When you have finished building your custom menu, make sure you click the Save Menu button.

    1. You create a custom menu.

    2. You add the Parent pages you want to display and arrange them in the order you want.

    3. Then you add and drop and drag the subpages below the appropriate Parent pages, and when you have everything arranged in the menu that you want you save the menu.

    4. Go to the “theme location” module at upper left on the menu page. Select your custom menu name from the pulldown labeled “primary location.” Click the save button in that module.

    5. Refresh your browser so that it isn’t possibly pulling a cached page, and view see your new menu with Parent pages and dropdowns to sub-pages.

    Note: If you did not checkmark the box on the top of the custom menu page to enable this __ Automatically add new top-level pages
    then that could be why the pages are not displaying.




    Thank you, thank you. Done deal!



    The link is I just love the journal look since that’s what the blog entries will be, once I get caught up with the background of how I got sober. Choco is superb for my purpose! Thanks so much.



    Yay! That looks swell now. :)

The topic ‘adding pages to menu’ is closed to new replies.