Adding videos… No More?

  • Author
  • #364916

    I have noticed that wordpress has come out with a new “video press” upgrade. Since this addition I have not been able to load videos from Dailymotion into my blog. Before this time, it seemed to work relatively easily. Does anyone know if this has been discontinued because wordpress is trying to get some $ for videos in blogs. I enjoyed having videos in the blogs, but find the $60 US that wordpress is asking for a little steep for a year when I was able to do it free a month ago.

    The blog I need help with is


    The video shortcodes that has should still work just fine. They do on my test blog.

    I’ve had issues using the “insert video from URL” thing and have resorted to using the shortcodes directly. I have also found that putting the shortcodes into the visual editor does not work consistently, so I now always put the code into the HTML tab which seems to always work (as long as I don’t mess up on the URL or the code).

    This support page has links to all the different supported video types and they all identify the shortcodes and how to use them:


    Thanks alot. I had used the shortcode in the visual editor and it wasn’t working. Swithing to HTML did the trick! Thanks again.


    You’re very welcome.



    I’m having the same problem – old videos that worked before no longer work. FYI, they were all youtube videos. I followed the directions on the link posted (and nothing happened, since the directions were what I’d been doing); I also clicked on shortcodes, but that routed me to the same directions again. Btw, love how their “sample” video looks just like my non-functioning vids. I also tried copying the “embed” html codes from my youtube video’s site (as opposed to the url option on youtube) and pasting that into the html editor, and same problem.
    Here’s the exact link I’m working with, though all my old videos are doing the same thing. ;

    Thanks in advance!



    That video works fine for me on your blog.

The topic ‘Adding videos… No More?’ is closed to new replies.