Need help? Check out our Support site, then

Admin Page Snafu

  1. Two days ago, my security certificate for the admin page of my blog was revoked by my Firefox 3.8.6 and 3.6.7 beta browsers (along with a few others). Now, the interface is vestigial, primitive, and inconvenient to work with. This support page is unchanged, though.

    How can I regain a secure connection to my admin page.

    The blog I need help with is

  2. Go to users > personal settings and check "Always use HTTPS when visiting administration pages" and then click save changes.

    Next log out of wordpress, clear your browser cache and cookies, restart your browser, and then go to the secure login URL for your blog (starting with https://) such as, .

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.