After Jetpack update on 27/4/2013 to 2.2.4 got a warning..!

  • Author
  • #1246625

    Having updated Jetpack twice within 2 hours on 27/4/2013 to 2.2.4 I got this very akwerd warning on my site in every post and page.
    The warning is:
    Warning: Missing argument 3 for Jetpack_Custom_CSS::editor_max_image_size() in /wp-content/plugins/jetpack/modules/custom-css/custom-css.php on line 1147

    Could anyone tell me what to do please?

    Best regards Silvie.
    European Bridal Fashion Blog

    The blog I need help with is



    The blog you specified at does not appear to be hosted at

    This support forum is for blogs hosted at If your question is about a self-hosted WordPress blog then you’ll find help at the forums.

    If you don’t understand the difference between and, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It’ll help people to answer your question.

    This is an automated message.



    I suggest looking for an answer to your question here first > If you do not find one then the Jetpack forum is at If you don’t have a username account at, click and register one on the top right hand corner of the page that opens, so you can post there.



    It seems to get solved by replacing line 1147 in /wp-content/plugins/jetpack/modules/custom-css/custom-css.php like this:
    instead of
    static function editor_max_image_size( $dims, $size, $context ) {
    it should be:
    static function editor_max_image_size( $dims, $size, $context='' ) {
    so that argument 3 is not missing, just blank.


    Hello Admin2013,

    Thanks a miljon, problem solved but how did this happen? I have never had any problems.

    Best regards,



    This is the support forum where the information above is of no use to free hosted bloggers. May I suggest you post that into the WordPress.ORG Jetpack support forums please? It will be of use to bloggers here >



    thanks Admin2013, you saved me ^^


    Thank you..admin2013.. :)


    Adim2013 – you are my hero!!!

    Saved me here – had exactly the same problem as other focus. The 1147 line correction is perfect!!




    Hi all!

    This issue has been fixed and will be included in the next release, thanks for bringing it to our attention. Also, please remember that under most circumstances, editing the plugin files isn’t a good idea as your changes will be overwritten in the next update. However, in this case, of course doing the change is fine to temporarily fix the error. :)



    Thank you so much. Will you please close this thread?



    Thanks timethief, done!

The topic ‘After Jetpack update on 27/4/2013 to 2.2.4 got a warning..!’ is closed to new replies.