aghh !Can't load photos into my photo blog! Icon missing!

  • Author
  • #754907


    I’m currently having a small meltdown because the icon in the Edit post Screen for uploading photos has completely disappeared!
    I have a photo heavy blog so this is a disaster!

    Can anyone please help me to “activate” the possibility to load photos again or is it a WP-wide problem???
    Any clue when we can expect a fix?

    Thankingyouverymuchly! kind regards… Kiwidutch

    The blog I need help with is



    I am new to this site..haven’t used it much…I have never got any comment on any of my blog..why this is so?:(




    Your comment doesn’t appear to be in *any* way related to my problem??!!

    For your question I’s suggest you ask it in a separate forum post question so that people who can help might see it,…

    …but as far as I can see from your site, you don’t post so very often, There are quite literally millions of blogs out there and it takes time to build a following…
    …probably longer if you don’t post very often.

    Also for all blogs (not just yours) the vast majority of people read and lurk and just a few comment, that’s frustrating sometimes for a blogger, but it’s a fact of life and it”s totally normal.

    My advice?… don’t blog to get comments, blog because you love to write and have something unique and interesting to say. ..produce Quality, … if you do, you increase the possibilities of comments, otherwise patience is the only other answer I can give you. You say you are new, so give it time.



    WordPress just released a new media editor. All media uploads will be accessed by the camera looking icon first on the left. HOWEVER, when I attempt to use it the editor does not come up. Screen goes grey but nothing else appears. Effect is the same – I cannot upload any media at the moment either.

    Hopefully someone will provide some guidance. This is a serious issue.



    @kiwidutch You should be seeing three icons above the text box of the visual editor. First one (Camera+music) icon is the icon which will be used in uploading photos.


    Other topics on here have suggested clearing the cache and cookies and maybe switching browsers. The new Media Insert looks to be a little buggy




    Edit: Gave was meant to be Have :(



    Thanks ieslivewire and wpgaurav,

    I found the icon ok, but can’t work out how to use it…

    Here’s a runthrough of what I’ve tried so far…
    attempt one…

    1) I clicked on the camera/media icon
    2) upload new media –> then ‘select files’
    3) My Picture Library (hard drive of my PC) appears, I select a photo, and open it, it loads, and I scroll down and add a caption, then I click on “save all changes”
    4) I find myself back in the Media Library and can see the photo but it’s “unattached” to my blog post, I click on ‘attach”and it says ‘find posts or pages”
    5) a list of my PUBLISHED post titles appears but none of my unpublished titles, even if I type in the name of my unpublished post it doesn’t seem to do anything at all, certainly it doesn’t take me anywhere.. there appear to be no further options.
    6) I go to my unpublished blog post in progress and there are NO photos :(

    attempt two…
    1) click on camera/ media icon
    2) click on ‘library’, the Media Library appears. I click on ‘add new” and then “select files”and everything from there is the same as step2 on attempt one…

    Result? … enough mouse clicks to give me RSI , a lot of frustration and still NO photos in my blog post.

    Please!!!! What am I doing wrong????

    (I made some screenshots of the process but can’t figure out how to display them in this post)

    Could anyone give me (simple) step by step instructions please?



    Thanks for the link timethief,

    I’m off to try that now… will report back soonest with the results.

    Cheers… Kiwidutch :)


    It’s a problem with the new media loader. Still buggy



    1. How are you connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.

    2. Are you using http:// or https:// see

    3.Which browser and version of it are you using?

    4. Have you tried clearing your browser cache and cookies?

    5. Is your browser version up to date? You can upgrade any browser version here.

    6. Do you have third party cookies enabled?

    7. Do you have JavaScript enabled?

    8. Do you have another browser you can try?

    9. You can use this link to see if your Flash is up to date. If it’s not up to date then this is where to download and install the latest version of Flash.



    Will you please answer the questions I posted above addressed to kiwidutch?



    Ouch Timethief,

    I’m as technical as a brick LOL so don’t understand all of the questins you’ve put but:

    – I have a brand new laptop (weeks old) ,
    – use Chrome,
    – have a fast ADSL (? is it called) connection, whatever it is, it’s (usually) quick and I know it’s *not* dial-up*…
    – I (think) I also have firefox on the computer and I will try via that too

    I DID go to the link you gave me and I can successfully add photos into the Media Library, the problem is getting those new photos into my unpublished blog post.



    YES! YES! YES!!!!!!!

    I went to the link you gave me:

    4. Have you tried clearing your browser cache and cookies?

    and followed the instructions given for Google Chrome (= spanner on right side of screen, click on “tools” in the drop down menu and then on ‘Clear browsing data”)

    the computer did a little bit of thinking and then closed all my open windows, went back to WP (logged in) and when to my post in progress.

    I clicked on the camera/media icon and got an option to “drop in ” or download, (no clue how to drop in so I tried download, I could then go to my photos on my hard drive and select a photo, … scrolled down to add the caption and then “insert into post”…

    ( btw it *didn’t* go through the Media Library at all this way)

    Et Voila!!!! It WORKED!

    You made my day, I am SUCH A HAPPY BUNNY now!!!

    To anyone else struggling like I have for the last two hours, please take heart, I’m a technical dunce of profound proportions so if I can get this to work there’s a very high chance you can too :)

    I’m still on flippin’ crutches but if I COULD dance a little happy Jig, right now I would!!!

    SO many Thank-You’s to everyone who’s helped out in this thread, I outlined what I did that worked in the hope that it also helps someone else who’s having this problem.

    WP Volunteers and members are the Coolest!
    Thank you!



    YES! ♫ happy dancing ♫ I ♥ happy endings. :) You’re welcome and best wishes with your blog. :)


    DH mucked around with a bunch of things and finally got mine to work. Thanks for all the input. It is very frustrating that these system upgrades are initiated without prior warning and what seems to be very little official support. Thank you very much to all the forum volunteers for stepping up



    Woo hoo! Thanks for sharing your good news. Happy blogging!



    Yes Timethief,

    I ♥ happy endings very much too!

    best wishes for your blog too :)


    Great that you are now getting photos into your posts too …Here’s to happy blogging (in full technicolour, WITH pictures!)



    Answer to this problem:
    You havr to click on ‘Insert Into Post’ instead of ‘save all changes’.

The topic ‘aghh !Can't load photos into my photo blog! Icon missing!’ is closed to new replies.