Akismet blocking non-spam comments

  • Author
    Posts
  • #683723

    justalillost
    Member

    I’ve noticed lately that my # of blocked comments by Akismet has been going up little bit by bit. Sometimes it shows up in the “Spam” queue so that i’m able to review, and it ends up being a legit comment from a reader. Other times, it goes directly to being blocked by Akismet.

    Is there any way to change settings for Akismet to not be THAT diligent? Considering almost everything that’s shown up in the queue so far has been legit comments, I’m wondering about the ones that are automatically being blocked.

    Thanks!

    The blog I need help with is justalillost.wordpress.com.

    #683817

    justjennifer
    Moderator

    First of all, if it truly is not spam, then unspam it and Akismet will learn. Be very cautious as to what you consider not spam as some comments sound completely normal, until you look at the email address and website they’ve included in their details. Truly dangerous comments, such as those linking to malware infected sites, are blocked by Akismet, show up in the numbers for spam comments, but you’ll never see it.

    If you have a lot of free time, I suggest clicking on the “spam” and “Akismet” tags you’ve added over there in the sidebar and reading some of the earlier discussions.

    #683818

    justalillost
    Member

    Thanks.. yeah, they’re actual legit comments from readers that are getting stuck in spam..

    #683888

    airodyssey
    Member

    Out of curiosity, do you have an example of such comments?

    #683917

    justjennifer
    Moderator

    @airodyssey-There seem to be a lot of people commenting with links, which certainly could trigger Akismet to block them.

    @lostwithsawyer- see if increasing the allowed links in comments by 1 doesn’t help cut down on commenters being caught in the spam net. You can adjust your settings under General Settings>Discussion Settings
    http://en.support.wordpress.com/settings/discussion-settings/#comment-moderation

    If your commenters still get stuck in spam, then have them fill out the form here http://akismet.com/contact/ hit Enter twice and mark the button “I think Akismet is catching my comments by mistake” and all the pertinent details.

    #683959

    justalillost
    Member

    @justjennifer – Ooh, I didn’t know you can change that! I’ll try it out – thanks!!

    @airodyssey – a have a mostly-book blog.. so a lot of fellow book bloggers comment to their pages/reviews/weekly memes..

    That’s probably/hopefully what it is.. thanks all!

    #684108

    kardzbykris
    Member

    @justjennifer – thank you for the information provided above. my commenters are not getting stuck in spam, but i am getting stuck in others’ spam. For some reason Akismet is catching my comments by mistake, too. I have filled out the form to contact akismet above, and hope this will be resolved in due course.

    And for the record – this is my first comment in the forum – and I just want to say how impressed I am with all the resources and helpful information available via wordpress.com.

The topic ‘Akismet blocking non-spam comments’ is closed to new replies.