Animated .gif feature image

  • Author
    Posts
  • #617109

    sassicapra
    Member

    Hi, I’ve uploaded an animated .gif to my blog sassicapra.com. I have used it as the feature image of my post so that it becomes the homepage main image. But when I do this the animation stops working… if I put it in the post it works.

    I’ve noticed from other trouble shooting forums .gifs stop working if you link them? Could this be the issue. If it is, can I change the automated link in the CSS code?

    I havn’t changed the size of the image or anything like that. I’m using the ‘structure’ theme if that helps.

    Let me know if you have any other trouble shooting for me, I would realy like to be able to feature animated gifs

    The blog I need help with is sassicapra.com.

    #617230

    timethief
    Member

    Did you upload your gif and then resize it? If so then that’s where you went wrong. In order for an animated gif to play, it must be full size. Make sure the gif is no larger than the maximum width for your theme’s post area. If it is, then resize it on your computer before uploading it.
    http://wpbtips.wordpress.com/2009/07/23/maximum-image-width/

    This is a post on the Structure theme I believe you will benefit from reading. That theme has a featured post and they way the theme is coded to behave is explained in it. http://wpbtips.wordpress.com/2010/05/01/introduction-to-structure/

    #617232

    timethief
    Member

    EDIT: “featured post” above ought to have been “featured image”

    #617233

    sassicapra
    Member

    this is all i could find in the css that related to the feature image…

    #homepagetop .featuredimage {
    float:left;
    display:block;
    background:#f5f5f5;
    width:620px;
    height:380px;
    overflow:hidden;
    margin:0 30px 0 0;
    padding:0;

    #617234

    timethief
    Member

    Please read the Introduction to Structure post I linked to above.

    #617377

    sassicapra
    Member

    Hi thanks I’ll have a read tomorrow and let you know how I go. I created the .gif at the exact size it appears, so it shouldn’t have anything to do with sizing.

    #617378

    sassicapra
    Member

    Hi Timethief, I had a read and it made no reference to being able to or not being able to load animated .gifs… anyother ideas on what the problem could be?

    #617380

The topic ‘Animated .gif feature image’ is closed to new replies.