Animated GIF works in text editor, not in site preview

  • Author
    Posts
  • #1281146

    This is a bit of an odd problem. I know the standard rules for putting in animated gifs (like they need to be uploaded full size and they need to be smaller dimensions than the space of your text). I’ve followed those rules, and as a result a gif shows up in the text editor and animates just fine. Also, this is a gif I made myself on imgflip. I have it saved to my computer and it’s on the internet too. Don’t know if that makes a difference.

    But anyway, when I go to the page preview the image shows up broken, with a weird little picture of a landscape instead of the standard red X in the corner. If you go to the website, it’s the bottom of the first post on the page. Anyone know how to fix this?

    The blog I need help with is tragicallymainstream.wordpress.com.

    #1281222

    Also, I should say that you can click on the broken image and the gif shows up in a new window. What’s up?

    #1281229

    raincoaster
    Member

    What is the URL of the post in question and what is the URL of the gif?

    #1281231
    #1281234

    raincoaster
    Member

    That gif is not in that post.

    #1281238

    I’m not exactly sure what you mean there. It’s there, it’s just showing up as a small empty box with a little picture of a landscape in the top left corner. It’s right near the bottom of the post, above the italics “God, 2004 was a good year.”

    #1281240

    raincoaster
    Member

    AH, I see it now. The code there reads:

    <a href="http://tragicallymainstream.files.wordpress.com/2013/05/locations-map-fl-ga-only.gif"><img class="size-full wp-image-100 aligncenter" alt="#nellystrong" src="http://tragicallymainstream.files.wordpress.com/2013/05/locations-map-fl-ga-only.gif?w=500&h=491" height="491" width="500"></a>

    How about you edit that in the Text editor to simply
    <a href="http://tragicallymainstream.files.wordpress.com/2013/05/locations-map-fl-ga-only.gif"><img src="http://tragicallymainstream.files.wordpress.com/2013/05/locations-map-fl-ga-only.gif" ></a>
    and see if that does the trick?

    You also have span tags all over the place. I hope you have gone to Settings->Writing and selected “WordPress should correct invalidly nested XHTML” so that you don’t get HTML errors in your blog.

    #1281247

    Didn’t know about the span tags (was trying to make links black and not blue. Is there a better way to do this?) but I got rid of the extra ones.

    But unfortunately the gif hasn’t changed. Basically now it’s just over on the left side of the page and no longer has a caption. Hmm… I just am not sure. Again, you can click the little image in the text and the actual gif will show up on its own page. It just won’t show up in the text.

    #1281249

    raincoaster
    Member

    Have you changed that setting I told you to? If not, do so now and then try and edit the post and see if that fixes it. If there’s a persistent HTML issue like an open tag that will fix it.

    #1281252

    Yes, although you referred to a different gif. The one you told me to change (the map of florida and georgia) is a static gif and shows up just fine. The other gif has this url: http://tragicallymainstream.files.wordpress.com/2013/05/1n8ke.gif

    It’s the car bouncing.

    Anyway, that also had some funky formatting so I just made it simple, copy and pasting the code you gave me and just switching the url so that the right gif would show. But that still didn’t change anything. The gif still comes up as a little error thing at the bottom of my post.

    Unless you’re seeing something different. Do you see the bouncing car animated gif at the bottom of my post? Is this just an issue with the way my web browser is set up or something?

    #1281272

    I’m just going to bump this.

    #1281274

    raincoaster
    Member

    Don’t. If I have suggestions, I make them. I’m not playing coy trying to get you to bump threads.

    #1281355

    Any ideas?

    #1281356

    1tess
    Moderator Emeritus

    You need to upload the animated gif to your library in the exact size you want it to display on your site. Then insert it into your post. Do not change the size of the gif.

    #1281362

    justpi
    Member

    Make sure the GIF is RGB color, not Indexed color.

The topic ‘Animated GIF works in text editor, not in site preview’ is closed to new replies.