animated gifs

  • Author
    Posts
  • #386771

    rjesiono
    Member

    I can’t seem to get an animated gif to play in a post. I saw many forum discussions on putting animated gifs into headers, but I simply want to put one in and have it animate in a post. The first frame of the animation shows up in the post- if you click on it, it opens a new window where the animation play. Is there any way to have it automatically play within the post itself? Thank you!

    The blog I need help with is rosemarykate.wordpress.com.

    #386872

    Do not link the image. In the post editor, click on the image then click on the edit image icon at the top left of the image, then click on “none” in the “file URL section, click “update” and then click “update post.”

    #386878

    rjesiono
    Member

    Thank you! Unfortunately, this didn’t work. Any other ideas?

    http://rosemarykate.wordpress.com/

    #386879

    rjesiono
    Member

    What’s strange is that it plays in the editor, but not on the blog itself.

    #386897

    Make sure you insert it in real size. Animated gifs won’t work if resized by the uploader.

    #386907

    yeah add real size images and it works just well

    #386958

    rjesiono
    Member

    Excellent, thank you!

    #387248

    cafecitopei
    Member

    thanks panaghiotisadam, it works perfectly with your advise!

    #387259

    wrueter
    Member

    I am also trying to insert an animated gif into a post, but am unable to get it to work. I have uploaded it as the original size and inserted into my post as the original size, but while it works in the editor window it won’t work on my blog.

    http://mydinnertime.wordpress.com

    #387260

    wrueter
    Member

    Posted too soon. I figured it out.

    #387263

    joulupukki
    Member

    And what did you figure out? I’ve got the same problem, can’t make it work neither. Not in original size nor with nor without link.

    And it seems, that depends on changes in wordpress, as I had no problem with an animated gif in a post couple of weeks ago. Now the same gif isn’t animated anymore. Any clue?

    #387264

    @joulupukki: Link to the post in question please.

    And always paste the exact URL of your blog when asking questions here, or link your nickname to your blog (as explained in the Sticky 8 Things to Know Before Posting). Helps us help you.

    #387265

    awakeproject
    Member

    Do not click the original size button and leave the fields with width and length empty. It works for me: http://awakeproject.wordpress.com.

    Had problems getting the gif to work before leaving the fields blank.

    #387266

    bunkalearner
    Member

    Awakeproject,
    Thanks! This tip seems to work in my blog (http://kanjioftheday.wordpress.com)… jeesh. One post fixed, another 90 or so to go. Perhaps WordPress’ latest updates did this? All my animated gifs did work until a couple of days ago…
    Thanks again

    #387267

    pinkmitzi
    Member

    Thank you thank you. I went nuts last night trying to figure out why the new gifs in todays post were not working. This is def some kind of new glitch. By leaving the width and length fields empty in th advance settings it fixed it.

    #387268

    OK, I don’t even know what you’re talking about. Mine isn’t working and I don’t have any advanced settings or anything else. I get to choose sizes and right/left justification, but that’s it. It defaults to left justification and I just left everything alone.

    I’m just getting started. http://www.designodyssey.wordpress.org.

    Any ideas?

    #387269

    1tess
    Moderator Emeritus

    @designodyssey

    Is this your blog: http://designodyssey.wordpress.com/
    (the link in the post above goes to: http://wordpress.org/ )
    In HTML—
    Change
    <img class="alignleft size-full wp-image-38" title="Headspinner" src="http://designodyssey.files.wordpress.com/2009/08/headspinner5.gif?w=144&h=177" alt="Headspinner" width="144" height="177" />
    to
    <img class="alignleft size-full wp-image-38" title="Headspinner" src="http://designodyssey.files.wordpress.com/2009/08/headspinner5.gif" alt="Headspinner" />

    Or, in visual editor, edit your gif by clicking the mountain icon, advanced settings and delete this from “source” (after “…headspinner5.gif”):
    ?w=144&h=177
    and delete the numbers from “size” so they are blank

    #387270

    1tess
    Moderator Emeritus

    The mountain icon appears when you click on your gif (or jpeg). On the top left of the pop-up window, it says “Edit Image” and “Advanced Settings.” Click on the Advanced Settings tab.

    #387271

    mharding
    Member

    Cheers leaving the width and length fields empty worked a dream!

    Check it!

    http://mharding.wordpress.com/

    #387272

    bunkstrutts
    Member

    Yeah, it works fine for a new post. What about the several hundred .gifs I’ve posted every Friday for the past two years? Is WP gonna fix the glitch, or am I looking at archive drudgery? –Bunk

    http://tackyraccoons.com/category/gif-animations/

The topic ‘animated gifs’ is closed to new replies.