Need help? Check out our Support site, then

Any idea why Jetpack won't work for me since the suggested 3.2.1 update?

  1. I have a self hosted wordpress blog but I'm currently unable to re-install the jetpack plugin since the suggested update to version 3.2.1 - before this, jetpack was working perfectly and I had complete access to site stats, the integrated twitter widget and gravatar amongst other handy jetpack features...
    I checked the forum for guidance, and came to understand some jetpack features are integrated into the 3.2.1 version? - Though I may still be mistaken...
    I initially assumed my web host was the issue, but we couldn't get around the issue, (we tried accessing, deleting and reinstalling the files manually - but to no avail)
    I also tried accessing, downloading and re-installing (via upload) from ) - but get the error message "Destination folder already exists" - I have searched for the "destination folder" but as such, I'm having no luck...
    I'd very much like to revert to using jetpack - I initially thought reverting to an older version of wordpress would have solved the issue...
    Any advice or suggested solutions would be greatly appreciated!
    Blog url:

  2. Can you please tell us which version of Jetpack you're using? 1.2.1 is the latest version.

    If you aren't using 1.2.1, can you please try upgrading to that?

  3. Thankyou for the reply!

    Ah... It would be version 1.2.1 that I'm "using"... I tried again anyway, (downloaded from and uploaded the zip file via "Plugins>Add New>Upload" and it popped up with:

    "Destination folder already exists. /home/linweb06/k/

    Plugin install failed."

    So I'm still quite confused at the moment...

  4. Are you able to delete the previous Jetpack version from the Plugins section in your blog's dashboard. Otherwise try to access your site through FTP and delete the Jetpack folder inside at /home/linweb06/k/

    Once it's deleted you may want to try and reinstall the latest Jetpack version.

    Sorry for the inconvenience.

  5. All of the Jetpack plugins have been deactivated and deleted before I tried reinstalling the latest version but it still displays the same message... I will have a word with the web host and see if we can try it your way, (though I think we recently tried it that way without success...)

    I'm not sure if it makes any difference, but apparently a "stylesheet is missing"...?(mentioned in the themes menu near the bottom of the page under "Broken themes")

  6. The stylesheet would be an issue with a theme you've uploaded, not Jetpack.

    If you can remove, or have your hosting provider remove, the Jetpack directory, please try reinstalling again by searching for the plugin via Plugins -> Add New in your Dashboard.

  7. Oh dear it is no longer jetpack that is the problem. The whole site does not display properly - im not sure if it maintenance mode. Also dashboard does not display but I can install and activate themes. I have tried doing this but nothing changes. Have looked for a .maintenance file and I cant find one. Should I just reinstall wp? Any other ideas?

  8. Your blog is a self-hosted blog, which we really can't help with outside of Jetpack issues.

    To clear up any confusion, and are two different entities. has complete support and documentation sites for self-hosted/installed versions of WordPress via their Codex and Support Forums.

  9. Cheers, I reaslised that yesterday! Thanks anyway

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.