Need help? Check out our Support site, then

API is invalid

  1. Hi there,

    I've got my API-key from and I want to use it on my blog for Akismet, but when I enter my API-key it says it is invalid.

    Any help on this?

    Thank you!

  2. Still no idea on this one? (thanks)

  3. I'm having the same problem. I have a blog here and one on my domain name site. I just upgraded to WP2.0 over there. It says I need an API key from I've got one from my blog here. I've tried repeatedly to use it and get the same API invalid error message that you do. :-(

    Since this is common, I wish someone would tell us what to do about it. :-(

  4. victoriacarolina

    There've been a couple of things posted to do/watch for on the .org support forum: wait a day or so to try it again; and make sure you are typing the api key in, not copying it from an email, an editor like notepad or wordpad, or a web page.

  5. Most people who report this problem have an issue with their host. Make sure that your host allows outgoing HTTP requests to and it should be fine.

  6. Well, duh! I was copy and pasting it because it's such a long jumble of characters. Typed it slowly and carefully and voila! Plugin activated. A ton of spam eliminated already! Thanks a million for this plugin! (and the tip on how to activate the key!) :-)

  7. victoriacarolina

    Yup. That's probably the single biggest stumbling block.... it's incredible how much dreck copy n paste will introduce!

  8. I'm sorry to say that I'm still having problems even while typing mine in manually :/

  9. victoriacarolina

    Check with your host as advised by Matt then.... good luck!

  10. I'm running it on my own server, and no hosts are blocked there. I can communicate with in any other way, and I'm sitting in my office, so...

    I also tried to empty the saved formdata in Firefox, and I tried to enter the code manually in FF and IE, no luck whatsoever... :/

  11. Can anyone tell me which server the API-key is checked against?

    It was my firewall that blocked access.

    Is it only to allow or should I add any other? (thank you)

    And oh, what ports should be opened to make authorization towards the API-system work?

  12. I added the IP for and (same one) to my firewall's "allowed hosts", yet no luck with getting through to authenticate my api-key.

    What other hosts or which ports should I add to the safe / open-list?


    EDIT: I've done some tracing in my firewall logs, and the IP is "". For anyone having the same problem, allow this IP and you'll be fine.

  13. If you're using the API key, you're probably trying to get to You can whitelist that specific IP, but I can't promise will be at that IP address forever.

  14. Thanks for the heads up on this one.

    Note: I've installed a new firewall solution on my end, I'm now using Firestarter and it's working just fine. No problems with the authentication of the API-key etc.

    Though, I hope that this thread will help anyone that's experiencing similar problems with their API-key.

  15. Hi everyone. I've been experiencing the same problems with the Akismet plugin activation that other people here have described. Unfortunately, it appears to be neither a firewall issue nor an incorrect API key issue.

    I've tried both copy-and-paste of the API key and carefully typing it in, both to no avail. I still get 'invalid key.'

    I've also checked with my hosting provider, and he tells me that there's no restriction on outgoing HTTP requests, so getting to shouldn't be an issue. I checked, and I am able to SSH in to the server and connect to and without any problems.

    Any other ideas as to what the problem might be? Any help would be appreciated.

  16. Any other ideas as to what the problem might be? Any help would be appreciated.

    I don't know what Control Panel you're using for your host nor what level of access you have. Both CPanel and Direct Admin (What I use on my service) have a method of doing a traceroute from the box from the control panel. See if you can reach from the box that your site sits on.


    Aside: I wonder some times what names we give our computers. I just wound up using Greek characters myself....

  17. drmike wrote:

    See if you can reach from the box that your site sits on.

    Hmm. As noted earlier, I am able to SSH into the box and use lynx to get to and So the firewall isn't stopping me.

    However, the traceroute from cPanel doesn't work. I'm trying to track this down. I'll keep you posted.

  18. Alright. Looking at the akismet.php file, I find where the URL gets constructed. Through some not-very-creative use of echo statements, I see that it's making:

    (I've replaced my key with xxxxxxxxxxxx)

    When I check this link in a browser, I see that I'm getting 'invalid' back.

    Any other ideas? I'm thinking it's time to contact a dev.

  19. If you're the same person who went through Akismet support earlier, I think your prob has been fixed.

  20. I'm having the same problem. Invalid key. I own my own server and there is no firewall.

  21. And you followed the suggestions listed above? :)

  22. OK I keyboard entered it in instead of cut an paste. Seems to be an issue with cut'n paste I guess.

  23. Has happened before. Sometimes with me, cut and paste will add in a blank space.

  24. I have tried the following:

    1) cut and paste API key
    2) keyboard enter API key
    3) waited a couple of days and tried again
    4) my host ( is not aware of anything blocking outgoing HTTP requests.

    But my API key is still not working....

    Here's a stupid guess: since my user name is different from the separately hosted blog user name (admin)...would that make a difference?

    I'm out of ideas...

  25. Honest answer, not sure since I don't know how the key is generated. I would send in an email to support at this domain and ask them for assistance. This is something that I can't help with here in the forums.

    Good luck,

  26. thejeffcho

    I too am hosted with APlus.. and my key does not work either..

    Hope someone figures this out..

  27. I'm wondering what part of what the Moderator said that did you not understand {she asked politely}

    "Honest answer, not sure since I don't know how the key is generated. I would send in an email to support at this domain and ask them for assistance. This is something that I can't help with here in the forums.

    Good luck,
    Posted: 2006-06-14 20:10:35"

    BTW If you are web hosted then the web host your paying should be taking care of this business for you over here

  28. Actually Akismet gets handled here as well since this is where they get the keys from.

    Best bet though would be to send in a feedback or an email directly to support at this domain since by posting here on a resolved thread from many months ago is just typing words instead of bringing it to the attention of someone who can help you.

  29. I also get "Your key appears invalid. Double-check it."

    I've both cut'n'paste and carefully manually entered.

    My host is HostRocket.

    And, even with above withstanding, Aksmit has caught 1,591 spam in little more than a month. So go figure.

    Not really a problem, just a curious fact. Thought someone here would like to know.

  30. Your key will be correct.

    The error message is because Akismet cannot access the Akismet server. The problem is one of three things:

    - either Akismet is being denied access to the internet if you are hosted locally behind a firewall, or

    - the server you are on lacks the ‘fopen’ function which Akismet needs or

    - your host might need to know that the default-installed SELinux security precautions (on Fedora4) causes this problem. With SELinux disabled, it works.

    Talk to your host.

Topic Closed

This topic has been closed to new replies.

About this Topic