Audio | What reason for an audio MP3 file not playing

  • Author
  • #110093


    I created two test posts, each with a separate mp3 file which is stored on (streaming is allowed).

    Test Post 1. mp3 file of 12mb. On starting, it just says buffering and does not play at all.
    Test Post 2. mp3 file of 430kb. Plays absolutely fine.

    Both at 44.1khz.

    What reason for an audio MP3 file not playing



    Please provide links to the posts in question.



    Just guessing, but there may be a size limit to the buffer and 12mb is too big. 12mb is bigger than many attachment allowances on free email accounts after all.



    It’s possible that, if you check in the visual editor, the one that keeps buffering is a live link, as opposed to a broken, text-only link. Check in the Edit page, and if the link to the MP3 is highlighted, use the broken link icon to break that. Then it should work. Even if it was right before, sometimes if you edit the page it changes and you have to re-break the link.



    Thanks TT, Dirk and Raincoaster:

    I checked through the FAQs and did not see anything on the size of audio files that could be an issue.

    However, I uploaded an edited version of the buffering file – at about 7.45mb – and that works fine.

    I will also delete the 12mb file and reupload and link into the entry, assuming that maybe the upload did not complete properly.



    I have similar problems. The audioplayer I use in my post seems to work on and off. I had a large mp3 file (13 MB) that I cut in half. First it kept buffering, then it worked fine, and the last few hours it keeps buffering again. I checked the broken link, that was allright. What else could it be?

    Oh and a second question: would it be possible to put two audioplayers in one post? Since I cut the MP3 in two pieces, I thought I’d put in two audioplayers with the first and second half so people could still listen to the entire file.


    P.S. this is the link



    Sounds fine to me. Two players within a post shouldn’t be an issue.


    You mean the MP3 works when you try it? Why doesn’t it work for me then? Well if it works for you I guess it’s OK and it’ll work for other people as well. :s Could it have something to do with MusicWebTown where I host the MP3’s – that maybe they aren’t very reliable and I should try some other, like Or wouldn’t that make any difference? I’ll just put in the two players then. Thanks for testing.


    I’ve asked this question before, but it’s still (again) appropriate I’m afraid. Is there a common reason why the audio player doesn’t work? First it did work for a very short time (about an hour or so), then it worked for *some* people (but never for me) and now nobody I asked can listen to it. The green buffering bar is visible, but it keeps on buffering and doesn’t play. I did all things correctly, link is OK, music is stored at musicwebtown.

    I’m on the verge of ordering the space upgrade, if it would help just uploading my mp3’s and then play them, because this drives me crazy for a month already.

    If anybody would care to make the effort of listening and helping me out, I’d be so grateful. Here are a few posts that supposedly have music on them:

    Thank you so much!



    Well the first link, you’re using the URL of a playlist on a webpage, not an mp3. That’s probably why. It’s working for you from the beginning since it’s probably already cached in your browser.


    OK, I think I found the answer. Since I took all my mp3’s off of musicwebtown and stored them at, I don’t have any more problems. Neither did the people I asked to do a listen check of the mp3’s in my posts. Before trying, I also tried, but that seemed to give the same problems as musicwebtown. Thanks for all the feedback.

The topic ‘Audio | What reason for an audio MP3 file not playing’ is closed to new replies.