Authors not showing up on posts

  • Author
  • #343233

    I am just starting blog content, but the authors user names are not showing up under the posts, so to the average reader (not an admin) there is no way to tell who is posting unless the author says it in the title. How do you get the Author’s username to show up under the post heading? I’ve seen it on most other blogs. The Screen options choices only seem to help the admin view, not the actual site.

    The blog I need help with is



    The site linked to your name is not a blog, and we won’t be able to help you with that. If you have a blog here, please provide a link, starting with http.



    I’m seconding the question… and you can check out my blog.


    Moderator Emeritus

    No can do, without a link to your blog, starting with:



    I’m having the same problem. My blog is We have two authors set up and we have “authors” checked in the screen options. Please let me know how to fix!


    Moderator Emeritus

    That theme does not display the author’s name with the posts. You could add an authors widget to the sidebar, and it should sort articles by author.


    Is there any way to add it into the theme? I would also like to have my authors show up under the posts, but it seems I must not have a theme that allows that. Is there anyway around this? My blog is located at



    @racesinplace, no it cannot be added to the theme. That would require access to the underlying theme PHP script files and we do not have that access.

    You can add a byline to the beginning of each post such as, By Author Name or Posted by Author Name, or something similar. The second choice is to change to a theme that shows the author.


    Okay, that’s too bad, but thanks for the tip! :)


    You’re welcome.



    You can also use the author’s name as a category. That works well, and makes it searchable by author.

The topic ‘Authors not showing up on posts’ is closed to new replies.