Background won't show, it's just blank

  • Author
    Posts
  • #617558

    erlhov
    Member

    I just upgraded by adding a domain and the custom css upgrade (haven’t touched the css yet) and now suddenly the background is just white whatever I do. No changes that I make actually shows, not with other themes either. Help?

    Thanks!

    The blog I need help with is hovgaards.com.

    #617662

    timethief
    Member

    Hello there,
    I see your blog is wearing the Paper Punch theme but I do not see a custom background. I loaded the same theme into my test blog and had not trouble at all uploading a background image and displaying it.
    Are you sure you clicked “save changes” after you unploaded the image?
    Does the image have one of these extensions?
    Images
    .jpg
    .jpeg
    .png
    .gif
    What is the size of the image?
    http://en.support.wordpress.com/images/troubleshooting-images/
    Which browser and version of it are you using?
    What exactly happens when up try to upload background image?

    #617667

    erlhov
    Member

    Hi,

    Thanks timethief!

    Yeah the image is a jpg, only 52 kb, it’s like a dark wood pic. I’m using the newest Chrome version, but I’ve tested the site in safari and firefox too. Same there, just blank. I just now tested the site on my iphone and here the background shows! So weird.

    Everything happens as it’s suppose to when I upload the background. I click choose file, upload and save changes, then the background shows in the preview square and it gives me a message “Background updated. Visit your site to see how it looks.” But then it just doesn’t show on the site when I check it.

    #617668

    timethief
    Member

    Without doubt you need Staff intervention. Here’s the contact link. Please be sure to include all your details in your support ticket. http://en.support.wordpress.com/contact/

    #617685

    First off, you need to go to settings > reading and set your blog to show perhaps 5 posts at most per page as your site loads really, really slowly for me on my wireless internet connection.

    Go to the CSS edit window, delete anything that is right now in the CSS edit window and paste the following in there and then click save stylesheet.

    body {
    background: url("http://erlhov.files.wordpress.com/2011/05/darkwood5.jpg") repeat fixed left top #0E0D0D;
    }

    When doing CSS here, what you are going to want to do is to add only the specific selectors, and the specific declarations you are adding or changing to the CSS edit window and then your additions or changes will overwrite the existing. Do NOT paste the entire stylesheet into the edit window.

    The problem was that the standard CSS uses the short form background declaration as such:

    background: url(URL of image) repeat scroll 0 0 #F3F3F3;

    And what was entered for your background declaration was the long form stuff (as below) and it will not override the above short form declaration used in the original CSS (as above).

    background-attachment: fixed;
    background-color: #0E0D0D;
    background-image: url(URL of image);
    background-position: left top;
    background-repeat: repeat;

    If you had not added any CSS at all yet, then this might be a bug.

    #617689

    erlhov
    Member

    Wow, thanks, that worked! Brilliant.

    On settings > reading I set Blog pages show at most: 5 posts, and Syndication feeds show at most: 5 items. But still, as you can see, the home pages still has loads and loads of posts….

    Btw, how can I change the title of the home page (hovgaard’s notebook) and the menu text from grey to black (using css)?

    Any other changes you would recommend?

    Again, thanks a million.

    Cheers,
    Erlend

    #617690

    timethief
    Member

    @TSP
    Thanks. :) This thread was in the wrong forum and I didn’t twig to what I ought to have.

    #617700

    G’day TT and you are welcome.

    ‘m not sure if they put the background in through appearance > background or if they used the CSS, but what was appearing in the CSS was inconsistent with how the original theme CSS did it and that was what was creating the problem. If they DID put the background in through appearance > background and what I saw was the result, then there is something going on with the theme or with wordpress (bug).

    #617715

    timethief
    Member

    @TSP
    Understood. :)

    Hopefully erlhov will tell us if he/she DID put the background in through Appearance > Background or not.

    #617720

    erlhov
    Member

    I just did as TSP told me in his first post, so it seems that the background image is changed through CSS, not through Appearance > Background. Do any of you know how to change the colour of the headline (hovgaard’s notebook) using CSS? It’s grey now and therefore hard to read.

    I tried adding to css:
    h1
    {
    color:#0E0D0D;
    }

    But nothing happened…

    #617728

    This is where the site title color is set.

    #title a:link, #title a:visited {
    color: #0E0D0D;
    }

    And here is where the “hover” color is set.

    #title a:hover {
    color: #000000;
    }
    #617729

    timethief
    Member

    @erlhov
    We need to know whether or not you did upload a background image here > Appearance > Themes > Background prior to me trying to help you, so we can determine if there is a bug or not.

    #617749

    erlhov
    Member

    @TT
    Yes, I did upload a background image there prior to that, but, as explained, it wouldn’t show before I took away the css that was there and replaced it with the css TSP gave me.

    Thanks again! All fixed:)

    #617750

    timethief
    Member

    Thanks and happy blogging :)

    #617753

    Just getting the CSS upgrade, but not yet having done anything with it should not have wiped out your background. I expect it might be a bug.

    #617754

    timethief
    Member

    Yep me too.

The topic ‘Background won't show, it's just blank’ is closed to new replies.