bbPress eats URLs with "??"

  • Author
    Posts
  • #1353109

    iqatrophie
    Member

    I noticed that bbPress seems to have difficulties with URLs containing “??”. It’s usually some CSS or script files referenced in the HTML header I’m trying to reference during support in the german forums. Take this one for example:

    http://s2.wp.com/_static/??-eJyNkOFOBCEMhF9IJJeNp3+MzwIs6/a2UEKL6769XZPDRBPivyn9OhnG7sUEyhKz2ILtHTLbVK42MNvZ8Qq65EedHuyAdHOCbLyrf8jUzB3m5jlUKAJqaRdCpH3Er/QRq/HNe4x6LQfGjkMO2GZ9vrEVDbl5+uxiZIqwnVdRigub+Z5GOOQFMsjRxfCDK1UJdMY6S2EElSvtpi9G171D3QdK5l+dFmIxCzqovwq6s7LGpHlK81Zqw8OoKSSHP/hber1Mz9N0fXqZLrcvnjfGjg==”>http://s2.wp.com/_static/??-eJyNkOFOBCEMhF9IJJeNp3+MzwIs6/a2UEKL6769XZPDRBPivyn9OhnG7sUEyhKz2ILtHTLbVK42MNvZ8Qq65EedHuyAdHOCbLyrf8jUzB3m5jlUKAJqaRdCpH3Er/QRq/HNe4x6LQfGjkMO2GZ9vrEVDbl5+uxiZIqwnVdRigub+Z5GOOQFMsjRxfCDK1UJdMY6S2EElSvtpi9G171D3QdK5l+dFmIxCzqovwq6s7LGpHlK81Zqw8OoKSSHP/hber1Mz9N0fXqZLrcvnjfGjg==

    The blog I need help with is iqatrophie.wordpress.com.

    #1353346

    amightywp
    Member

    Hiya Martin,

    Have you tried using the Link tag in conjunction with such links to see if that overcomes the double question mark issue? Let me know if that solves it or if it is still a problem!

    #1353357

    iqatrophie
    Member

    2nd attempt with link tag:

    Testlink

    #1353358

    iqatrophie
    Member

    Ok, this seems to work. :)

    Note to self: Mustn’t forget to add a link tag to all links in case it contains two question marks.

    Cheers
    Martin(IQ)

    #1353365

    amightywp
    Member

    Glad it’s working! Thanks for letting me know.

    #1353374

    iqatrophie
    Member

    You’re welcome.

    On the other hand I think this is still a bug with bbPress as it formats URLs, containing two question marks, the wrong way. ;)

    http://support.wordpress.com/??linkendsbefore

The topic ‘bbPress eats URLs with "??"’ is closed to new replies.