Beep Beep Boop screen is a joke. Is this a glitch?

  • Author
    Posts
  • #1996914

    gracejiyoung
    Member

    @basilikimetatroulou

    A) I insert an image from the media library in the new editor, and the caption is not there when I hit the pencil to see the “Image details”.
    B) I copy an image from an old post to the new editor (using the HTML code) and the caption is missing, again.
    C) I copy a gallery from an old post to the new editor, the gallery no longer exists and the images are showed now individually one-by-one, and the captions fled again.

    I’m sorry, but I cannot reproduce these images. I am able to grab the html code for an image and gallery (with images and captions) and they are all viewable when publishing from the new editor as seen here:

    https://cloudup.com/czFXqJU151u

    If you are still having issues with this, please open up a new ticket and tag with modlook.

    #1996915

    teepee12
    Member

    ‚Äč test file.png
    ‚ÄčThis is as good a capture as I can get. It doesn't show anything because nothing happened to show. Nothing is very hard to capture.

    #1996916

    gracejiyoung
    Member

    @basilikimetatroulou

    Please, let the box with the URL untouched so the users can SEE it,
    this is very important,
    and, please again, provide the users with an “Edit” button in case they want to change it

    Thanks for the clear explanation! I completely see what you mean now about being able to edit/preview the slug before publishing. I have reported this to our developers. Thanks for this!

    #1996917

    rossau
    Member

    Staff wrote:

    **Update**

    The next time you select to use the classic editor instead of the new editor, we’ll remember it! From then on you’ll be directed back to the classic view instead, you won’t have to select it every time.

    Please note, if you end up having to clear your cookies for any reason, you’ll need to opt out of the new editor again.

    Thanks. Finally. That was the best you can do. We have our old editor back on all places. Please leave it like this!

    Ad URL edit: This is essential even for German-language blogs if you want to have a clear and “readable” URL of your postings. The automatic URL generator doesn’t translate umlauts and there will be ugly spelling errors in it.

    Love it how you insist on changing/adding one error/missing feature after another in a row until the “new” editor will look and work exactly the same as the “old” one. Still not getting what’s the reason for this sisyphus work.

    Next time please tell us IN ADVANCE what you want to change and why. Thanks.

    #1996918

    teepee12
    Member

    FYI – The site does NOT remember the choice except if I click “new post” from the dashboard “Serendipity” menu. Everywhere else — if I want to fix a typo on an already published post and click edit or if I click “New Post” on the right side of the bar on the dashboard — I get the Hideous New Post dysfunction.

    This piecemeal approach is no way to do software development. If there’s a bug, you can fix IT. You can’t fix a whole software update that is flawed in its concept and basic approach. Doomed to failure, but worst of all, WE are condemned to use it or find another host.

    It’s YOUR idea. YOU should be condemned to use it.

    #1996919

    nixedsims
    Member

    @gracejiyoung,

    THANK YOU (general-staff “you”) for giving us the option to opt-out of the new editor! This makes me a much less disgruntled blogger. :)

    #1996920

    gracejiyoung says: “The next time you select to use the classic editor instead of the new editor, we’ll remember it!”

    That’s very good. I frequently clear out all but a few essential cookies. What cookie is it stored in — the “wordpress” cookie or the one for that specific blog?

    #1996922

    leesbirdblog
    Member

    Ditto, I hate the new editor. Bring the old one back ASAP!

    #1996923

    teepee12
    Member

    It does NOT remember the choice of classic editor except as a selection in the dashboard’s home menu. Everywhere else, no matter how many times you select “classic mode,” you will continue to get the “new” editor.

    #1996924

    desertbeacon
    Member

    There is a reason most people block pop-ups (associated now with the preview function?) not only to avoid annoying ads, but also for security reasons. I hope the developers take these considerations in mind. The “Classic Option” is a welcome relief, and I hope this will be a permanent feature.

    #1996925

    rossau
    Member

    tepee12 wrot:

    It does NOT remember the choice of classic editor except as a selection in the dashboard’s home menu. Everywhere else, no matter how many times you select “classic mode,” you will continue to get the “new” editor.

    There must be something wrong with your cookies. I checked it (Safari): Once I select “classic mode” I’m getting the old editor everywhere (even on “edit”). I closed and opened Safari and it stayed like this.

    #1996926

    nixedsims
    Member

    I run Firefox 31 and it remembers it just fine for me as well, both when I create a new post and when I edit an old one.

    #1996927

    teepee12
    Member

    I can try dumping the cookies, but ye gads, that’s a lot of work resetting everything.

    #1996928

    windwhistle
    Member

    @gracejiyoung I did a giant eye roll when you said you didn’t understand why we wouldn’t want the Publish button at the bottom, for when we finish writing. It’s because nobody is finished when they get to the bottom. They’ve only just begun. Then we add an image, or several. Preview to see how it looks. Resize it, preview again. Edit some text. Preview to see how the lines break around the image. Edit, preview, edit, preview, until the widows and orphans are gone, the paragraphs don’t look too long, all the spelling and punctuation is correct. Add tags and/or categories. Oops, don’t forget that hyperlink; what was the name of that post? Choose a Featured Image. Finally, ready to publish. Where’s the Publish button? Clear down at the bottom where I haven’t been since I finished my first draft.

    #1996929

    teepee12
    Member

    Thank you windwhistle for describing the process. Baffling that WordPress “happiness engineers” are so clueless.

    Selecting Classic Mode in Chrome does is not remembered. I cleared the browsing data, all the cookies, rebooted, tried again and then again. The only place it remembers is on the home menu of my site. Everywhere else — most annoyingly when I click edit to correct an error on an already published post — I get the awful new version.

    I notice all the responders tested this functionality on other browsers, none of them were Chrome users.

    Have YOU tested this on Chrome? Oh, and I put an exception for popups on WordPress.

    I’ve done everything I was told to do.

    Is this another case of it doesn’t work because I’ve got a big site with a lot of posts (2600+) and a lot of pictures (5200+)? Because I’m assuming you want your premium users to hang around, that this is not designed to drive us away. Which, if this doesn’t get resolved, it will eventually do.

    #1996930

    windwhistle
    Member

    @teepee12 I use Chrome. My stats indicate that the majority of my readers do too. Chrome is now the most popular browser on the Internet. Putting previews in pop-ups is ridiculous. Everyone uses pop-up blockers. Far fewer users, I suspect, know how to disable the blockers for one particular site.

    #1996931

    teepee12
    Member

    Chrome is popular because of its simplicity I think. You don’t need a search engine — the browser IS a search engine. But it does work differently than other browsers. Downloading is often a two-step operation where it’s a single step on other browsers. But I like it better than any other browser I’ve ever used and I think that’s everything pretty much.

    I’m just working around the updates as long as I can. I feel like WordPress, with each change they make, is sending me a message: “We don’t want you. Find another home.”

    I hate the idea of moving, but they are clearly going in a direction that has nothing to do with what I need or want … and eventually, no matter how obtuse I seem to be, I will say “Okay. I’m outta here.”

    Sad. All they had to do was leave well enough alone.

    #1996932

    davidderrick
    Member

    New point. Why does the new editor place a thin frame around each image I insert? Why is it taking this decision for me?? I need to decide myself whether I want a frame.

    #1996933

    sundrop74
    Member

    I find the Beep Beep Boop screen to be extremely childish and annoying. I can live with most of the changes, but that really drives me nuts.

    #1996934

    davidderrick
    Member

    Re that last point (Why does the new editor place a thin frame around each image I insert? Why is it taking this decision for me?? I need to decide myself whether I want a frame) …

    I can remove the frame (border) by typing 0 (zero) in the picture editing box, but it leaves the picture shrunk by the amount of the border that I’ve removed.

    And I have to remove it every time I insert an image. It does not remember my preference!

    Yet another thing that has not been thought through.

The topic ‘Beep Beep Boop screen is a joke. Is this a glitch?’ is closed to new replies.