Need help? Check out our Support site, then

blank home page

  1. thederricogroup

    Hi! Everytime I write a post I was expecting it to appear on my main page along with the picture I include for each of them. Not the case. My main page is totally empty and in order to access any of my posts you have to click on the right hand side where it says "recent posts". When people go to my blog I want all my posts to appear on the screen one after the other so that viewers can scroll down all the way to find the first one. How do i get my posts up on my main page!?
    Blog url:

  2. Go here > Settings > Reading and tell me what your settings are.

    Reading Settings
    Front page displays
    __Your latest posts
    A static page (select below)
    Front page:
    Posts page:

  3. There is only one page in a blog for posts. The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top.

    If you do not want all the posts to show on the front page, then you can create two pages ie. a static front page example “Welcome” for your site and a “Blog” page for posts.

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.

    Front page displays
    _Your latest posts
    _A static page (select below)
    Front page:
    Posts page:

Topic Closed

This topic has been closed to new replies.

About this Topic