Blockquote isn't working.

  • Author
    Posts
  • #759134

    mbukee452
    Member

    Blockquote not working. Text not rendering properly. Anyone else having problems?

    The blog I need help with is mbukee.wordpress.com.

    #759284

    airodyssey
    Member

    Hi. Could you show us a specific post or page (http://…) where “blockquote” is not working?

    #759289

    mbukee452
    Member

    Gve me a second…

    #759291

    mbukee452
    Member

    http://mbukee.wordpress.com/?preview=true&preview_id=4&preview_nonce=4b99f8415b

    The very bottom should be blockquoted. It appears blockquoted in Visual but not in HTML, and not in View Site.

    Thanks.

    #759298

    timethief
    Member

    We Volunteers cannot see “previews” of draft posts and pages only you and Staff can. Will you please contact Staff directly for assistance? Here’s the link http://en.support.wordpress.com/contact/ After you use the searchbox, under the search results, at the bottom of the page there will be a section that says “Have you found the answer to your question?” You can choose either “Yes I found the answer to my question.” or “No I didn’t find the answer to my question and I would like to contact support for help.” The no option will reveal the contact form.

    #759322

    mbukee452
    Member

    It isn’t a draft post.

    #759338

    timethief
    Member

    I saw “preview true” in the URL and assumed it was a draft post that had not been published. I will flag this thread for Staff attention.

    #759365

    Howdy, it’s not working because of extra HTML formatting in your post. Did you paste in text from Microsoft Word?

    If you click the HTML tab when editing that post you’ll see sections like this:

    <span style="font-size: 11pt; font-family: verdana; word-spacing: large; line-height: 125%;">

    That’s what’s causing the blockquote styling to not appear properly.

    #759381

    mbukee452
    Member

    I did paste from Word but the exact same coding I have already used with another theme and the Blockquote worked. It seems to be then that this code conflicts with this particular theme.

    #759382

    mbukee452
    Member

    And even without the formatting, it still doesn’t work.

    #759386

    raincoaster
    Member

    Give us the actual link to the published post. And NEVER copy-paste from Word without using the special Paste from Word function, because this is what happens.

    #759388

    timethief
    Member

    WORD is not web compliant. It contains extraneous code. Unless your use the correct icon to paste the WORD code into the pop-up box so the extraneous code gets stripped from it you will eventfully experience this problem over and over again. Go here please and enable this > Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.” Then open your most recent post open in the editor, make one minor change such as adding a space and then deleting it, and then click “Update Post.” Does that change anything?

    #759397

    mbukee452
    Member

    http://mbukee.wordpress.com/493-2/

    here is link to a test page. I have not copied anything on here from Word. The blockquote doesn’t seem to work when viewed this way. When viewed in Visual in the editor it does work though, but it doesn’t come through in the preview or in the published view or anything.

    #759398

    mbukee452
    Member

    I’ve enabled those settings. Still no changes.

    #759399

    The problem is, the CSS stylesheet for that theme does not have any styling in it for blockquotes, so everything is rendered just as a normal paragraph.

    Staff need to fix this. The blockquote selector is totally empty.

    blockquote {
    }
    #759400

    I’m tagging this to have it moved to the themes forum so hopefully one of the theme team will see it and fix the problem.

    #759401

    Rich, there’s also this:

    #content .type-quote blockquote {
    padding: 15px;
    border-radius: 15px;
    -webkit-border-radius: 15px;
    -khtml-border-radius: 15px;
    -moz-border-radius: 15px;
    color: white;
    background: #535353;
    }

    Up to a few days ago, bqs in DePo Square were like that (white text in a grey bubble). So this is a new bug.

    #759403

    The problem is, there is no class showing in any of the parent selectors for .type-quote and that is not being applied to the blockquote in their example test page.

    That I think is for the “quote” post type rather than standard blockquotes.

    #759407

    DePo Square doesn’t support alternative post formats. As I said, up to a few days ago bqs in DePo Square used to be white text in a grey bubble. I know it for sure because that’s what my latest post is about, and I checked the themes again before publishing it:
    http://wpbtips.wordpress.com/2011/11/19/blockquote-style/

    #759418

    I can’t remember which theme I was looking at, I think it was on one of the theme demos, but I remember seeing the .type-quote in a sample “quote” post. I’m not entirely sure exactly where I saw it.

    The point is, DePo Squared has no blockquote styling defined in the CSS for a standard blockquote HTML tag, so it just takes on standard paragraph styling.

The topic ‘Blockquote isn't working.’ is closed to new replies.