Blog pages show at most setting

  • Author
    Posts
  • #440916

    rhpt
    Member

    When I set the “Blog pages show at most” settings to 1, my blog still shows 2 posts on the frontpage. Is it possible to just show one post on the first page, and nothing else?

    The blog I need help with is r.amblin.gs.

    #441064

    timethief
    Member

    Hello there. You didn’t provide a link to the blog in question starting with http:// so I cannot answer you. There is a theme that display two posts on the front page and that cannot be changed. However, until you post the link to the blog in question I have zero to work with.

    #441066

    timethief
    Member

    I just read a bunch of threads and I think I found your blog. Id this it? http://r.amblin.gs/ If so it’s wearing the Inove theme and I just set my test blog to display only 1 page in the same theme with no problem.

    > Settings > Reading
    scroll down and change the number to one (1) on the following line and then click “Save Changes”.

    Blog pages show at most ___ posts

    #441068

    And if it’s that blog, the latest post has been erroneously marked as a sticky. Sticky posts override the “show at most” setting.

    #441089

    rhpt
    Member

    Ahh…That explains it! Is there anyway to make the sticky post the only post on the frontpage?

    #441091

    raincoaster
    Member

    Not as far as I know, and it would kill your blog stone dead if you did it. Literally everyone coming to your blog would think you never posted anything new.

    #441095

    timethief
    Member

    I’m with raincoaster on this. In fact I just blogged about it here http://onecoolsitebloggingtips.com/2009/12/29/static-front-blog-page-yay-or-nay/

    The bottom line: Don’t do it unless you don’t care about increasing traffic to it, and could care less about Google juice, or PageRank.

    #441097

    raincoaster
    Member

    Ah, you COULD make a static PAGE. I’d forgotten about that. But yes, it has all those drawbacks.

    #441098

    timethief
    Member

    @rhpt
    You had the blog set to display only one post. You had two posts and one was a sticky post. Maybe when you create a sticky post the software doesn’t count it and therefore displays the sticky plus one post.

    #441101

    timethief
    Member

    @rhpt
    I just went to my test blog which is also using the Inove theme. I created a sticky post and set the blog to display only one post like I explained here https://en.forums.wordpress.com/topic/blog-pages-show-at-most-setting?replies=9#post-424706

    Guess what? It’s only displaying the sticky post so that shoots the theory of the software not recognizing a sticky post and counting it in goes out the window. If you have set your blog up correctly to display only one post and you are getting two then I think we can conclude that you need Staff to intervene and sort this for you.
    http://en.support.wordpress.com/contact/

    #441130

    @timethief: It’s not a theory! Back when the sticky option was more prominent and lots of new bloggers marked all posts as stickies (misunderstanding what “stick to front page” means), I had seen several blogs with 30 or so posts on the front page (with the show-at-most option set to 10). You didn’t get the effect because you stickied a newly created post: try making an older post sticky and see what happens.

    #441195

    timethief
    Member

    Ahhh … thanks for chiming in – noted. :)

The topic ‘Blog pages show at most setting’ is closed to new replies.