blog post background

  • Author
  • #1258174

    My last 2 posts have a strange background that is unlike all the others. The purple dominates and gradually fades into white, blocking the sidebar Categories in white, when the whole post is supposed to be white. I searched & tried a few things to see what was causing this and found nothing.

    The blog I need help with is




    I’m assuming the purple should be on the side, but not within the post area itself?


    Hi, yes, that’s correct….although now it appears that the problem has suddenly been solved. I’m not sure, if you are able to see if from where you are, does the purple appear in the body of the blog post or just background edges?



    Are you able to add custom CSS? I’m still showing the incorrect style, but believe you can correct it by adding:

    #main {
    background: #fff !important;

    It looks like there are a number of rules for the background of that section and the gradient one is overruling the color, which is the root of our issue here.


    Hi..what is CSS and where can one add that? Thanks for your response



    Hi, no problem. My apologies for jumping ahead.

    CSS is the code/rules that define all aspects of style for a website.

    In your Dashboard, please visit Appearance->Customize->CSS (last on the right-hand side navigation that appears after clicking Customize).

    If you already have the Custom Design upgrade, you can paste CSS there, adding it to the bottom. ( )

    Please do let me know if you have the upgrade already (and thus can add the CSS as mentioned above). If not, please let me know and we’ll go from there.



    I checked the Customize setting and could find anywhere to add CSS. I saw the upgrade is $30. If this is something I have to pay for it doesn’t seem right, since everything was fine until the last 2 blogs. It appears to me that is an error that has occurred, and I am looking for a solution that won’t cost me any money…



    I agree with you completely. As a volunteer, I just can’t tell if you already had the upgrade or not.

    My thinking is that there may have been an update to the theme that caused this. I’m doing a little investigating on my end before kicking it up to the next level. Please standby! :-)



    Well, I can put this theme on my blog and it looks as intended. Still digging in.



    Okay, well, here’s what’s going on. The theme is coded to have the gradient to extend a certain percentage of the page. The longer the content is on the page, the longer the purple gradient will extend down the page.

    I think in your case, the most recent posts were long enough to make this behavior unpleasant, something not experienced before.

    My suggestions for the moment:
    1. Limit the number of posts shown on the home page (Settings->Reading)
    2. Use the “more” function to limit the amount of text that appears on the home page. ( details: )

    On the individual post pages, when there is a long entry, will suffer the same result too.

    Frankly, this seems like a bug and will ask the staff to review it.

    To the staff: The background gradient for the #main in the spectrum theme applies to the entire height of the content, thus changes based on the amount of content. With virtually no content, the gradient looks nice as a small splash of color above the site description.

    With a fair amount of content, the effect reaches far enough down to make other elements look poor (ref: the OP’s category listing in the sidebar).

    It seems that having the gradient limited to a small area would make the result more predictable and not negatively impact users with greater amounts of content.


    Thank you so much for your time and research! I can try making those changes you suggested, but I agree that this seems like a bug. I had to contact WordPress a week ago about an unusual ad appearing over my blog page where the Facebook link is. Also, I have been experiencing another odd thing, which is the inability to link a word to a website. It is simply not functioning normally, even from different computers. I think there is a virus involved and didn’t receive much help from WordPress when I first contacted them about it.



    The problem is in the post.

    Notice how only that post by itself causes its own share of formatting issues?

    An invalidly nested HTML element is causing the problem there, and it’s cascading down when viewed on the front page.

    Did you compose this post elsewhere and then copy and paste it over? I’m noticing odd things like HTML tags that our editor doesn’t insert and smart (curly) quotes.

    Checking “WordPress should correct invalidly nested XHTML automatically” at Settings -> Writing in your blog’s Dashboard and re-saving the post may correct the issue.

    Otherwise, I recommend just breaking down the post until you find the section causing the issue.



    Hi James,

    All due respect, that’s not the issue. Check out . I have one post that’s just dummy text pasted directly into the Text editor with only wpautop operating against it.

    The length of the content is causing the issue without regard to other formatting.

    On the OP’s site, deleting the node containing the April Forecast 2013 post from the DOM didn’t correct the issue as the length of the home page was still longer than the theme can reasonably handle. After deleting a number of nodes from the DOM did it begin to render most as expected/intended.

    Heading offline for the night, but thanks for looking into this.



    Hm, fascinating. I’ll pass this along to the theme team.



    @macmanx – Even the homepage of the Spectrum demo site looks to be “off”. You can particularly see it also in the sidebar, which looks broken up. Single posts and pages look as advertised. ;)



    Should also mention that I’m viewing currently in FF20.



    Thanks! I’ll add that to the bug report.


    Thanks to all of you for your replies…I’m still a bit confused about this issue. Is it possibly because for the latest blog post I used a different computer than I did before? I don’t understand why that would matter, but it’s the only thing different I did that I can think of.




    You didn’t do anything wrong here. The theme has a small flaw with it that causes this issue if the content displayed is greater than a certain length.

    My suggestions above on how to limit the amount of content shown on the home page is a temporary way to prevent your main page from displaying the issue.


    Thanks again! Not sure how to do that exactly but will figure it out. I wish that WordPress would take my issue more seriously because I am now solidly convinced that my site contains a virus. Just as an experiment I decided to make my homepage page static. Over my Facebook icon there is a constant flashing image of changing ads. This is why I wrote WordPress 2 weeks ago. They said they take these things seriously but nothing was done about the issue. I wrote Security again today. Here’s hoping…

The topic ‘blog post background’ is closed to new replies.