Blog post display messed up

  • Author
  • #476031


    Just noticing that my blog posts are displaying in a weird way. Top 2 are fine and then the rest look completely different — like they’ve flowed out of the template. If you click on the “weird” looking posts and open it up, it reverts back to the way it’s supposed to look on the blog. How do I fix it?


    The blog I need help with is



    They look normal to me. But in general, to fix this go to Settings / Writing and check the box labeled “WordPress should correct invalidly nested XHTML automatically”.



    Thanks. Went to the Settings/Writings and clicked on that …. still shows the posts after the first three splayed out. I knew something was out of whack when my sidebars weren’t showing up. But if you’re able to see it correctly, then I’m not sure what’s up! Thanks for the quick response.



    It’s still not displaying correctly. Had a friend call up my blog (someone in different location) and he sees the same problem, but — like me — doesn’t know how to fix it. (Posts start to display incorrectly with the “Jenna Black” post. If you call up the blog and scroll down, you’ll see it. And then — if you click on the post — it reverts back to correct form. It’s just when I’m scrolling the blog, it is messed up.


    Moderator Emeritus

    Is this the blog you are asking about:
    Can you link to “Jenna Black” post?



    hi Tess — No, the link to the blog is

    …. the top 3 posts on the homepage scroll don’t show my widgets. If you click on them — it looks fine. But the Jenna Black post is where things look “splayed” out on the homepage scroll. If I click on that “splayed” out Jenna Black post — it is fine. And then if you go to the older posts on the home scroll, everything is fine. So not sure why the change in display!

    Hope that makes sense.

    Thanks — Diana


    As tellyworth said, go to Settings > Writing and check the option “WordPress should correct invalidly nested XHTML automatically”. Then edit the post “What readers are saying about ‘Dead in the Family’” (make any insignificant change, e.g. add then remove a space) and click Update Post.

    And please paste the URL of your blog when asking questions here, or link your username to your blog (as explained in the Sticky 8 Things to Know Before Posting). We usually need that to give a relevant answer.



    Thanks. I did what Tellyworth said per my previous post. (Yes — I clicked on edit and made an insignificant change etc. I have been looking through previous posts to the forums etc.) I’m wondering if it’s something else though because my widgets don’t show up on my new posts. If you scroll to my older posts via the “homepage” it all looks fine. I’ve had this blog for a year and it’s worked very nicely!

    And like others new to this forum, I thought when I sent in my question — since it asked for my blog url — that it was posted. Sorry. Again — the link to my blog is

    Appreciate the suggestions.



    Panaghiotisadam, Tellyworth and 1Tess — Thanks for sticking with me and helping. The display is correct now.

    After Panaghiotisadam repeated that I should try Tellyworth’s suggestion again — I did. I’d tried it 3 times before — with the “WordPress should correct invalidly nested XHTML automatically” checked, made an insignificant change and updated on the post etc. without any luck. But — I did it again and this time made a significant change because I noticed in the “Dead in the Family” post that I’d saved it in html. I usually work in visual. So I switched that back to visual. And all of my widgets etc showed up. Not sure if that what was throwing it off, but everything is back now.

    Thanks again for the help and appreciate the patience.


    You’re welcome.

    With that option on, switching to visual then updating the post has the same effect as making any other change. The difference this time is that you edited the problem post while previously you hadn’t.

The topic ‘Blog post display messed up’ is closed to new replies.