blog post hyperlinks

  • Author
    Posts
  • #3004093

    I have set hyperlinks to my blog posts – these hyperlinks do not contain dates. But everytime I do a backup, all these hyperlinks automatically have dates added into them by the system – which of course means, that visitors who come to my site via those hyperlinks, end up on the 404 page. How do I configure the system to leave my hyperlinks as I have set them?

    The blog I need help with is www.naturalhealthrejuvenation.com.

    #3004242

    musicdoc1
    Member

    Hi,

    You can’t remove the publish date from a post URL on a WordPress.com site. Can you provide an example?

    #3004243

    musicdoc1
    Member

    Correction:
    Evidently the publish date may be removed with CSS customization, as described in the forum topic How to remove published date? However, CSS is theme specific, so I’d suggest that you request the correct CSS code to remove the publish dates from posts on the theme applied at the CSS Customization forum. Alternatively, you may add a “modlook” tag to the sidebar at right in this topic to call for staff attention.

    #3004277

    I have a blog post titled, Why was I born (first hyperlink below), to which I have directed a number of tweets via a hyperlink.

    I have recently changed my website host, and when the backup was installed, all the hyperlinks have the post date added (second hyperlink below).
    http://www.naturalhealthrejuvenation.com/why-was-i-born/
    http://www.naturalhealthrejuvenation.com/2016/10/14/why-was-i-born/

    I have spent hours scouring through my posts to remove these dates so as to not have visitors end up on the 404 page – but I’m looking for a permanent solution

    Thanks

    #3004302

    musicdoc1
    Member

    Hi,

    The link in the original post of this topic goes to the site https://www.naturalhealthrejuvenation.com/, which I took to be an undeveloped WordPress.com site, because of the secure protocol (https), the message “[site URL] is coming soon,” and the lack of any links or other content on the site. However, the site WhoIsHostingThis? indicates that the domain is hosted by “HETZNER (Pty).”

    Also, the links you’ve provided in your second post above have “http” instead of “https,” though each opens to the same URL as the link in your first post here.

    Ordinarily, requests about self-hosted sites are referred to the host and, if it’s is a WordPress.org site, to the WordPress.org support. However, since I’ve already engaged you here, I’ll tag the topic for staff attention and let them decide what course to take from here.

    #3004325

    supernovia
    Staff

    Thanks @musicdoc1

    That is a WordPress.org configuration, @naturalhealthrejuvenation. Check your permalink settings in wp-admin and you’ll likely be able to sort it out from there:
    https://codex.wordpress.org/Using_Permalinks

    If not, you will want to head over to https://wordpress.org/support for more troubleshooting. Good luck!

    #3004331

    musicdoc1
    Member

    @supernovia,

    You’re welcome. Did you notice the difference between hypertext transfer protocol of the link in the original post and the links in the second post by @naturalhealthrejuvenation?

    OP — https://www.naturalhealthrejuvenation.com/ (http secure)
    2nd post — http://www.naturalhealthrejuvenation.com/why-was-i-born/, and http://www.naturalhealthrejuvenation.com/2016/10/14/why-was-i-born/ (http)

    Also, did you notice that the two different ‘http’ links in the second post are somehow redirected to the one secure ‘https’ URL given in the first post?

    #3004334

    supernovia
    Staff

    For me, all of them redirect to https and a coming soon screen.

    We usually redirect http links to https too, for what it’s worth.

    #3004335

    musicdoc1
    Member

    Yes, they all go to the coming soon screen, but I didn’t think of the one in the OP as being redirected, since it has the same URL as the URL on the coming soon screen.

    We usually redirect http links to https too

    You mean if a self-hosted site is not open?

    #3004341

    supernovia
    Staff

    I mean on our servers, if someone types in http instead of https, we redirect them to https automatically. So I wouldn’t be surprised if their host is doing that as well.

    #3004342

    supernovia
    Staff

    Oh and to be clear, the redirect is just from http to https. The “coming soon” thing seems to appear on all pages and not redirect the URL.

    #3004343

    musicdoc1
    Member

    I mean on our servers, if someone types in http instead of https…

    Yes, but a mistyped “http” doesn’t seem to be the issue here, or not the only issue if it is one of the issues. Who’sHostingThis indicates that naturalhealthrejuvenation.com is hosted by “HETZNER (Pty),” and I thought that all self-hosted sites had “http” protocol. Yet, the ” coming soon” page has “https.” That’s where I’m confused.

    #3004344

    musicdoc1
    Member

    I called for staff attention because I thought it might be a Jetpack deal connecting WordPress.org and WordPress.com sites, about which I’m quite hazy.

    #3004345

    supernovia
    Staff

    I thought that all self-hosted sites had “http” protocol

    Ahh, no. Many might have https. Using your own SSL used to be quite expensive, but it isn’t anymore.

    #3004346

    supernovia
    Staff

    I called for staff attention because I thought it might be a Jetpack deal connecting WordPress.org and WordPress.com sites, about which I’m quite hazy.

    That’s perfect. This one is not that but whenever there’s any question on that, we’ll help.

    #3004349

    musicdoc1
    Member

    Thanks for the clarification! : )

    #3004355

    supernovia
    Staff

    No problem — thank you for your help here!

The topic ‘blog post hyperlinks’ is closed to new replies.