Blog shows all posts even when I change the settings to show 5 posts

  • Author
    Posts
  • #467414

    http://goofballcommittee.wordpress.com/

    Okay so I’m having this little problem where my blog shows all the posts on the front page, even when I select Reading Settings> Blog pages to show at once, and I put five posts and I click ‘Save Changes’. It is getting kinda annoying because it takes like a million years to load for slow internet connections.

    On the bottom it says ‘Changes may not appear until you create a new post or your news reader refreshes’. I saved the settings and made a test post, and it doesn’t work. Then I deleated the cookies and cache on my browser (Firefox), and saved the settings and It still doesn’t work. This forum is kinda a last resort because I just have no idea why this function is so complicated to me. Hopefully someone can help me…… Thank you for taking the time to read this and I greatly appreciate any feedback. Thank you!

    The blog I need help with is goofballcommittee.wordpress.com.

    #467567

    timethief
    Member

    I doubt that we volunteers can help you with sorting this. Blix is a quirky theme but I haven’t heard of this particular quirk with it before. As you have done all the right things to reduce the number of posts on your front page without success I recommend contacting Staff. http://en.support.wordpress.com/contact/

    #467586

    The reason this is happening is that you have every single one of your posts set as a sticky post.

    You are going to have to bulk edit all the posts in your blog, “unstick” them and save the changes.

    #467588

    timethief
    Member

    Aha! Why didn’t I twig to that? Thanks so much TSP. :)

    #467590

    Welcome TT.

The topic ‘Blog shows all posts even when I change the settings to show 5 posts’ is closed to new replies.