Blogging from TextMate

  • Author
  • #173472


    I have a problem which seems to be unique.
    I’m trying to set up the TextMate blogging bundle, and falling at the first hurdle.
    It asks for your xmlrpc string. Now, I have found that out, no problem:
    http://(email redacted)/xmlrpc.php
    But if I then try to fetch posts, I get this error:
    Received exception:HTTP-Error: 301 Moved Permanently
    Bizarre, given you can’t move blogs.
    My first instinct, based on searches, is to remove the www. to make the string:
    http://(email redacted)/xmlrpc.php
    But that just tells me
    Error: Bad Login/Pass Combination.
    Can anyone tell me what I’m doing wrong? I can’t for the life of me work it out…



    It should be as far as I remember. It’s been a while since I used the link.



    Yeah, that is the same link as http://(email redacted)/xmlrpc.php, its just the second one adds the username in as well.
    They both have the bad login/pass combination error…



    That link is right as katm says.
    Yours is the wrong link.



    I can promise, they are the same link in the eyes of TextMate.
    Regardless, if I use your link, it asks me for my username as well as my password before booting me to the same error.
    What I want to know is why I am getting a 301 error on wordpress. If you don’t believe me, I’ve recorded a screencast. I’d happily post it, if it would help the diagnosis.


    If I click on http://(email redacted)/xmlrpc.php your blog comes up. Now are you saying that if you click on a title to a post, you get a 301 error?


    Never mind, I just googled textmate.


    I think your answer is here: . I Googled “using textmate with wordpress” and found it.


    I must need food, I should have noticed that the link form he shows is what you are using.

    Again never mind {he says slinking away}



    Thanks for trying, thesacredpath.
    I stand by what I’ve been saying – this problem seems to be unique. There is certainly no mention of anyone else having it on google.
    A 301 error should be impossible. There is no way you can redirect on So why am I being told that I have?



    I’d not used TextMate before, so I downloaded the trial version to give this a go. I was successfully able to post to my test blog using the link type you’ve already given (ie I did, though, have to adjust the syntax of my blog settings within TextMate a few times to get it right. I don’t know if you’ve already checked it, but within TextMate, go Bundles > Blogging > Set Up Blog and make sure your blog is entered on a single line, eg:

    My Test Blog

    If that’s not the issue, the only other thing I can think of is whether you’ve got domain mapping (which I think you might have) and whether that breaks it in some way. Perhaps someone with experience of domain mapping could offer an opinion?



    Also, I just found this link, posted in another thread, which may offer some insight into the 301 error.

The topic ‘Blogging from TextMate’ is closed to new replies.