Bold, Italics, Strike-through: Won’t Go Away!!!!

  • Author
    Posts
  • #199769

    aaronhh
    Member

    My Blog at http://www.fvsueetclub.com has lost it’s mind! I am using the WordPress WYSIWYG to edit a blog page. And when I click bold, italic, or strike through, everything highlighted becomes bold, italic, or strike-through like it is supposed to. HOWEVER, clicking bold, strike-through, or italic again does not make the style go back to normal. Furthermore, if I look at the code side, there are tags all over the frickin place. It is like a war zone or something. Does anybody have any idea what the heck is wrong with my WordPress blog page editor??????

    #200027

    raincoaster
    Member

    It looks just fine to me. Are you pasting in from Word or another page online somewhere? Those can both cause horrible problems.

    Just an unrelated question: have you reviewed the differences between pages and posts? You’re about to run out of room in your header.

    #200029

    wiidude
    Member

    well, if u didn’t do the closing tag, then that can happen. you have to close your tags when you want to stop.

    #200030

    aaronhh
    Member

    I tried to put the word strong with the angle bracket things on both sides of the word strong in my post before the words “tags all over” and “war zone” not as a style, but because I was describing my problems with the strong tags. And, as it was supposed to (in this case), but not as I intended, it made the text following the strong tags bold. And now I can’t figure out how to edit my post to fix the error. So that is kind of funny. But this problem with my WordPress editor is not funny. I really want to know what the heck is wrong with the WYSIWYG.

    #200032

    aaronhh
    Member

    I’ll publish the page that I’m trying to edit so that you can see the problem which has occured. In addition to the styling problem, I also can’t get the editor to move the pictures and the text where I want them to go, so that problem is also apparent on the page.

    #200034

    raincoaster
    Member

    What browser and version are you using, and have you cleared your browser cache and cookies and tried reloading the page? Do that.

    #200035

    aaronhh
    Member

    The page is now published. The name is “Tutoring”.

    #200036

    raincoaster
    Member

    You are also going to have to give us the direct link to the post in question.

    #200038

    aaronhh
    Member

    Okay, I’ll try clearing the browser cache and cookies, but I can’t imagine how that could be causing the problem. What would cache or cookies have to do with WYSIWYG problems?

    #200039

    aaronhh
    Member
    #200041

    raincoaster
    Member

    Yep. That is a mess. So you’re trying to post two images, with some text and an email address? My advice is:

    Delete the post entirely. Start again. Before you start again, do the browser clear I recommended above. Do not post your email as a live link like that; obfuscate it or spammers will grab it.

    Your code is a mess. It’s easier to delete and start over than to fix it at this stage. Here is what I see:

    <div class='snap_preview'><p><a href="http://fvsueetclub.files.wordpress.com/2008/03/students-improve-through-tutoring.gif" title="students-improve-through-tutoring.gif"><br />
    <em><strong><strike><img align="left" width="601" src="http://fvsueetclub.files.wordpress.com/2008/03/students-improve-through-tutoring.gif?w=601&h=300" alt="students-improve-through-tutoring.gif" height="300" style="width:555px;height:217px;" /></strike></strong></em></a><a href="http://fvsueetclub.files.wordpress.com/2008/03/students-improve-through-tutoring.gif" title="students-improve-through-tutoring.gif"></p>
    <ol>
    <li> <a href="http://fvsueetclub.files.wordpress.com/2008/03/students-improve-through-tutoring.gif" title="students-improve-through-tutoring.gif">
    
    <ol>
    <li> <a href="http://fvsueetclub.files.wordpress.com/2008/03/students-improve-through-tutoring.gif" title="students-improve-through-tutoring.gif">
    <ol>
    <li> <a href="http://fvsueetclub.files.wordpress.com/2008/03/students-improve-through-tutoring.gif" title="students-improve-through-tutoring.gif">
    <ol>
    <li> <a href="http://fvsueetclub.files.wordpress.com/2008/03/students-improve-through-tutoring.gif" title="students-improve-through-tutoring.gif">
    <ol><em><strong><strike></strike></strong></em></ol>
    <p></a></li>
    </ol>
    <p></a></li>
    </ol>
    <p></a></li>
    </ol>
    <p></a></li>
    
    </ol>
    <p></a><a href="mailto:(email redacted)"><em><strong><strike></strike></strong></em></a></p>
    <p><em><strong><strike> </strike></strong></em><a href="http://fvsueetclub.files.wordpress.com/2008/03/tech-support-cartoon.jpg" title="tech-support-cartoon.jpg"></a><a href="http://fvsueetclub.files.wordpress.com/2008/03/tech-support-cartoon.jpg" title="tech-support-cartoon.jpg"><em><strong><strike><img align="left" src="http://fvsueetclub.files.wordpress.com/2008/03/tech-support-cartoon.jpg" alt="tech-support-cartoon.jpg" /></strike></strong></em></a></p>
    <p><em><strong><strike>Electronics Tutoring Available;</strike></strong></em></p>
    <p><em><strong><strike>$2.00 per hour;</strike></strong></em></p>
    <p><em><strong><strike>Send an email to: </strike></strong></em><a href="mailto:(email redacted)"><em><strong><strike>(email redacted)</strike></strong></em></a></p>
    <p><a target="_blank" href="http://www.webware.com/"></a></p>
    </div>
                  </div>

    My recommendation: Center the images and put the text in between them. Don’t TOUCH the list icons, etc. Keep it simple.

    #200042

    aaronhh
    Member

    I recently changed themes from “ChaosTheory” to “Andreas04”. I wonder if that could have anything to do with the problem? I read something about themes having the capability to change user preferences behind the scenes, the other day at the http://www.getk2.com site, but I didn’t understand what they were talking about.

    #200043

    raincoaster
    Member

    I really don’t think that would be the problem. It just looks like for some reason the HTML went haywire. Maybe there was a server hiccup or something.

    #200092

    isadora
    Member

    You described the problem yourself:
    HOWEVER, clicking bold, strike-through, or italic again does not make the style go back to normal. Furthermore, if I look at the code side, there are tags all over the frickin place.
    The visual editor is not MSWord and works a little bit differently: each time you click you add new tags. If you want to undo you have to hit [ctrl]+z (or on a mac [cmd]+z) on your keyboard.

The topic ‘Bold, Italics, Strike-through: Won’t Go Away!!!!’ is closed to new replies.