Need help? Check out our Support site, then Widget Cannot Save New Code

  1. In the Widget, I clear the default code: <embed src="" width="0" height="0" wmode="transparent" type="application/x-shockwave-flash"></embed>

    Then, enter the code from the website for the MP3 file I want to share: <embed src="" width="200" height="200" wmode="opaque" type="application/x-shockwave-flash" allowFullScreen="true" allowScriptAccess="always">

    When I save, I get essentially the default: <embed src="" width="200" height="200" wmode="transparent" type="application/x-shockwave-flash"></embed>

    I have done this successfully in the past, so I am at a loss what to do.

    Thanks for suggestions or fixes.


    The blog I need help with is

  2. The code has to remain the same as the one given by box. That is what gets pasted in the widget.

    Once you've uploaded MP3s on, they will automatically appear in the widget. You can also configure the widget to either allow or disallow downloading of the MP3.

    Direct embed codes or linking to a file on is only if you have a paid account and then, too, it has to be one of the allowed file types.If you don't have a paid account, it shouldn't work.

    More about the widget here

    More about audio embeds here

  3. Sorry! Forgot to close a STRONG tag. Mods, assist?

  4. OK-now I see. I've just reported to Support that the "go get some HTML code" link in the widget is broken and doesn't lead to the page it used to on

  5. @jennifer, fixed strong tag.

    We'll investigate the discrepancy via the support ticket. Thanks!

  6. We still can't use all the functionalities like "disallow downloading of the MP3s". Too bad...

  7. Unless something's changed on's side, you should be able to disallow download of MP3's by logging into the widget on your site. Use the down arrow in the upper right hand corner to get to the login box.

  8. I cannot modify and save the code of box,net widget (dimensions for width and height). The code always return the same.

  9. Where are you trying to change the dimensions, on or in the widget? If it's the widget, then use the boxes for width and height below the space where you paste the widget code, then save. The new dimensions should now show up in the space where you pasted the code.

  10. Oh my... Thank you Jennifer !
    We couldn't do that before if you read the first link you put :

    "It is not possible to stop anyone from downloading a file from your widget unless you have a fully private blog. Anyone who is able to view your blog can download the files."

    Now we can !

    But we can't choose the color like before :/

    The old code :

    <embed src="" type="application/x-shockwave-flash" FlashVars="subString=folderId=fyi8bb6p0s,color=000000,title=Zikmu !" wmode="transparent" width="220" height="258"></embed>

    The new code :

    <embed src="" width="220" height="258" wmode="transparent" type="application/x-shockwave-flash"></embed>

  11. @trigz-You are welcome! I've had a account since I signed up with (about 4 years) and as far as I know the widget was always configurable to prevent download of MP3 files. But in order to do it, you have to set up the widget first and then log in to the widget itself and change the settings there.

    But, having said that, I think that warning in the Support Doc is there to let you know that if someone accesses a file from within a browser they can still find a way to access it afterwards, even if it is not directly accessible. So still... (CYA clause.) :)

    Yes, I'm not sure what's going on on's end, but obviously there have been some changes. I haven't heard anything back from Support other than a cryptic "Hopefully will fix this soon". :/

  12. Oh Ok.

    So, wait and see.

    Thank you again.

  13. Ok, Jennifer! Thanks.
    But, when I try exchange the code, for exemple, using the option 'list', and no the default 'icon', to show the files, the new code generated by site is not saved.
    Sorry! But I think that this problem is in
    Thanks for your attention!

  14. @muccamargo, if you are having a problem on, take the default code as gives it to you and then see if you can change the settings in the widget once you've set it up on your blog. If you can't, I suggest dropping support a note.

  15. Just to add to this thread.... I have been using the wordpress widget for a couple years - the old style widget - now it no longer plays the files unless I am logged in on Not what I want obviously - no one else can play my music files! Any thoughts? Thx

  16. @gregdrums - The best thing to do would be to submit your problem directly to Support. One thing I did notice on your blog, is that some of the code seems to have escaped the widget, or at least I see some code under the widget in the sidebar. Might want to mention that as well.

    On the other hand, the good news is that it seems the "Go get some HTML code" link in the widget is working again.

  17. The same thing is happening with me...the widget sets up okay, but there are some lines of code under the widget. I've contacted support at, describing the issue, but they haven't gotten back to me yet.

  18. Extra code keeps reappearing beneath my widget as well. I delete all the code for it within Dashboard, paste in the original code that worked right for months, click Save and immediately the extra code is added back again. It will even add more code each time you click Save.

  19. Just went back to my test blog, cleaned out the widget code that I got from my existing account and proceeded to sign up for a new account using the "Go get some HTML" link in the widget. Copied the initial embed code from the sign up page on and pasted it into the widget, saved it and proceeded to get a line of code running under the widget on my test blog.

    Definitely odd. This does not happen with the "embed this folder in your website" code received from once inside your newly created account.

    @disembedded @moconfederate Please contact Support directly with this problem, as it's nothing the forum volunteers can help with. Please also point them to this thread in the forum. TIA

    Also for those interested:
    In the initial embed code the widget color is configurable; in the second it is not.

    In the initial embed code it is not possible to configure the widget to disallow downloads; in the second it is.

  20. same problem here. lines of code under the widget. hopefully someone will fix this issue. it's clearly a wordpress bug and not because I didn't touch the code that gave me.

  21. We can't give you support or feedback, because we don't have your blog URL.

  22. @mrcacadu, as mentioned above

    "Please contact Support directly with this problem, as it's nothing the forum volunteers can help with. Please also point them to this thread in the forum. TIA"

  23. Hi all, as @justjennifer mentioned the best way to get this fixed is if you can get in touch with us at:

    We'll work with things from there and try to get this all squared away for you. Thanks!

  24. Andrew-any news on this with On my demo blog I'm still getting the stray line of code under the widget in my sidebar.

  25. We have registered this issue and our developer will look into it.
    Thanks for reporting this!

  26. My blog is
    This is what I told Customer Support:

    I did:
    Followed the instructions from this link:

    Here was the HTML code I posted into the widget:
    <embed src="/resources/a66zuqgcem//static/flash//widget_player.swf" type="application/x-shockwave-flash" FlashVars="subString=folderId=07cufdp1kn,color=000000,title=Muntoo's WP Blog files" wmode="transparent" width="190" height="258"></embed>

    (Replace the "& lt;" with "<", and "& gt;" with ">")

    I saw:
    After saving, the code suddenly changed into this:
    <embed src="" type="application/x-shockwave-flash" FlashVars="subString=folderId=,color=,title=" wmode="transparent" width="190" height="258"><a href=\"/resources/a66zuqgcem//static/flash//widget_player.swf\">/resources/a66zuqgcem//static/flash//widget_player.swf</a>

    After refreshing the page, this was the new code:
    <embed src="" type="application/x-shockwave-flash" FlashVars="subString=folderId=,color=,title=" wmode="transparent" width="0" height="0"><a href=\"\"></a><a href=\"\"></a><a href=\"/resources/a66zuqgcem//static/flash//widget_player.swf\">/resources/a66zuqgcem//static/flash//widget_player.swf</a>

    I expected:
    The widget to display "", the proper title ("Muntoo's WP Blog Files"), and actually work. The code shouldn't have automatically changed.

  27. I have the same problem as Muntoo, and it has drived me crazy, cause everytime I make a change in my widgets, a line or two is added the end of the code, and the story goes on and on...!
    Any help?

  28. I have the same problem, it does not seems to work properly.



  29. keep sending your feedback directly to support as Andrew requested.

  30. I fixed the problem by going to, opening the widget folder, and getting the widget code. That code seems to work on my blog, although I can't change the background color.

    This is the code I used:

    <embed src="" width="190" height="258" wmode="transparent" type="application/x-shockwave-flash"></embed>

Topic Closed

This topic has been closed to new replies.

About this Topic