Need help? Check out our Support site, then

Broken Google Maps Iframe

  1. Dear Support Team,
    I have found a problem with a Google Maps iframe. Many of those maps are working in my blog, but one is broken. Please find the broken one in the following article It has been displayed as a map, but now it only shows the code. I tried to reinsert it, but I always fail. What is so different to my other maps which work fine. I promise this map has been displayed well a few week ago. Is there a change in WordPress? Can I change the map code?
    Any help is very much appreciated.
    Best regards
    Blog url:

  2. Could you please let me know which route/directions you've used in Google maps? I'm going to try and reproduce the things you did, to test where things to wrong.

  3. You will also find a link on my blog's page Here it is:,+Huez,+France&daddr=Besse+to:45.0620055,6.2159191+to:Mizo%C3%ABn,+France+to:Brian%C3%A7on,+Frankreich&hl=de&ie=UTF8&ll=45.063094,6.170883&spn=0.088876,0.129433&sll=45.057092,6.184101&sspn=0.044442,0.097418&geocode=FRAPsAIdfJhcACnbbGyFBmuKRzGrxzE1TuVjng%3BFUy9rwId2yheACk_SvlwaBSKRzGVFaz4ugZq9Q%3BFXWXrwId79heACmpgCSZsRaKRzGIjyf0Cd3VRw%3BFRhqrwId5bxdACmffvvd6hOKRzFAdb7kKqsIBA%3BFVgcrQId611lACkRQXQDaOSJRzGgqZf9pRkIBA&vpsrc=6&mra=dpe&mrsp=2&sz=14&via=2&t=h&z=13.
    It works fine with google maps and converts into
    This code has been displayed previously, but is broken now.
    I produce this in Google Maps by clicking the link icon and then by previewing and adjusting the map. I select big size and shift and zoom accordingly. Then I cope the produced code into the WordPress editor. After saving or previewing, it is converted into the code above.
    Thank you in advance.
    Best regards

  4. Very strange. I was able to get it to work with the code from rather than

    We'll look into this.

  5. Dear macmanx,
    Thank you very much for looking into this and for the very fast fix.
    Do you think it is safe to try adjusting the map according to my preferences or will I break it again? If you want me to wait, I'll better wait.
    Best regards

  6. Sorry, but I could not wait...
    I have created a private test page and have pasted the code from (instead of and end up with the same result. WordPress displays the text of the map code, but not the map:

    Privat: Kartentest
    Veröffentlicht am 14. September 2011

    Karte vom Plateau d’Emparis die zweite:


    The testpage can be found on the following link: I have set it to private as it shall not appear on my blog. I hope you can see it.

    Thank you and best regards

  7. I am not sure whether I have understood your question. I customize the iframe with the Google maps features (link icon / preview and customize map) in the following way: I change the zoom level, set satellite view, select big map and then I copy the code from the text field below this Google Maps window.
    I paste this code to the WordPress editor and save the changes. Compared to earlier attempts, which have worked fine, WordPress now displays the code instead of showing the inserted map. The fact, that I do not see the copied HTML iframe code, but WordPress converts it into an internal tag "[googlemaps]" indicated a sort of acceptance and processing by WordPress, but the display on the blog page fails.
    I hope this clarified the process.
    Please let me know, if I can help trouble shooting.
    Best regards

  8. What do you set the zoom level to? How many clicks in or out?

  9. If I understand the code above correctly (parameter z), the original map (with the full route) has been at zoom level 11 and the inserted map (showing a map detail) has a zoom level of 13. Thus I have zoomed in two clicks. I also verified this again in Google maps.

  10. It seems to be working fine at now.

    It looks like the trick may be just doing everything through

    Is there anything that I missed?

  11. Thank you again, but yes.
    The page "Kartentest" has been created to test, whether copying the iframe from works for me, before editing the original post "Plateau d'Emparis". The result has been, that it does not work for me either.
    As you can see from other articles, it worked earlier and I did not change anything in the procedure. Therefore I thought it might be a problem with a change in WordPress.
    One difference remains. I am logged into my google account while creating maps. Therefore language is German. You may not have logged in and the map you have inserted shows French language.
    I will try again without being loggen into my Google account later today.

  12. Hello again,
    I have tried several things, but the problem remains with this map.
    Finally I have tried a very simple map Route A to B without any special caracters like German Umlauts or French Cedille and the result is: it works.
    As a conclusion, it should be an issue with either the complexity of the map or the fact, that there are 16bit characters in the description.
    Can you please check whether there is an issue?
    To whatevver reason I cannot setup this map as desired.
    Thank you again.
    Best regards

  13. I'm going to put my money on the 16bit characters, but we'll definitely look into this. Thanks for helping us track down the cause!

  14. This must me the case (e.g. Briançon). Thank you for looking into it.
    Please do not hesitate to contact me, if I can help testing.
    Best regards

  15. I tried to continue troubleshooting. Here are my results so far:

    1) Umlauts and Cedille work fine (I could not verify out first guess).
    2) works fine as well as (no difference).
    3) Helper points on routed (small white circles) do not make any difference.

    I even succeeded the first time again to display the map "Plateau d'Emparis" (see, but point C as found by Google is off-track.

    Code 2 (working):


    Next I only shift point C back to the real track and export the map again to WordPress. This step has broken the map! (see

    Code 3 (broken):


    I never have been as close in finding the step, which breaks the map.
    One difference is, there is now a German "ß", but French "ç" and German "ä" did already work before. Up to here it does not seem to be too logical, but I hope you will find the bug.

    Best regards

  16. Thanks for the additional details! That will help quite a bit.

  17. thohenberger, I believe we have fixed the issue. The example you provided in your last comment here, for example, should be working now.

    Can you confirm that your embedded maps are working as expected?

    Thanks very much for providing such a thorough bug report!

    PS: Lovely blog :)

  18. Yes, great, the old test page with the code shown above (see now works out of the box without any changes.

    Marvelous support! Never dared to think of receiving such a high quality support nor experienced such a short reaction time, friendly communication and commitment with any other support team. If you know a site, where one can rank support services, please tell me, I for sure would give you the top-rating. Thank you very much!

    Now I can continue adding articles to my quite newly created blog.

    WordPress is great and a unique hosting service.
    Thank you for both.

    Best regards

Topic Closed

This topic has been closed to new replies.

About this Topic