Broken RSS feed

  • Author
    Posts
  • #762263

    gogohanneson
    Member

    A larger site http://www.eat-la.com will be featuring my blog but the site’s wordpress guy says there is a problem.

    Here are his comments:

    “http://uwant2gogo.wordpress.com/feedz

    As you can see in the above link, their RSS feed is broken and cannot be imported into our blog.”

    Thanks for any help.

    The blog I need help with is uwant2gogo.wordpress.com.

    #762378

    auxclass
    Member

    They should try spelling thing right – http://uwant2gogo.wordpress.com/feed/

    #762381

    gogohanneson
    Member

    So, the RSS feed IS working and the guy just added the “z” and that’s the only problem?

    How do I check to see if the RSS feed is working?

    #762385

    raincoaster
    Member

    The feed is working as long as it’s spelled right.

    http://uwant2gogo.wordpress.com/feed/ If you look at that in a feed reader, you’ll see it works fine.

    #762389

    gogohanneson
    Member

    when i click on http://uwant2gogo.wordpress.com/feed/, this is the message I get:

    “This page contains the following errors:

    error on line 555 at column 30: Input is not proper UTF-8, indicate encoding !
    Bytes: 0x03 0x31 0x31 0x22
    Below is a rendering of the page up to the first error.”

    What am I doing wrong? How do I look at it in a feed reader?

    #762392

    You appear to have some errors in some of your posts.

    Go to settings > writing and select “WordPress should correct invalidly nested XHTML automatically” and then click “save changes.”

    Now, starting with your latest post, open it in the editor, make one minor change such as adding and then deleting a space, and then click “update post.” Revalidate your feed at http://validator.w3.org/feed/ and if it validates, you are golden. If not, open the next post and do the same thing till the feed validates. There might be one recommendation that will hang around after the feed validates (“In addition, interoperability with the widest range of feed readers…”), but you can ignore that.

    #762397

    gogohanneson
    Member

    Hello again, Sacred Path, and thanks once again for your very much appreciated help.

    I followed instructions through “Revalidate your feed….” and got the message below. I know you said the “interoperability” message could be ignored but should I continue to open and revise the posts? I see that there are specific erro rs and where they are but not how to correct them. I tried to Google what the problems were but the explanations didn’t make sense.Thank you in advance for any advice you can give or where to look to figure out the problem.

    This feed does not validate.
    line 569, column 226: XML parsing error: <unknown>:569:226: not well-formed (invalid token) [help]
    … -image-2459″ title=”Artisanal LA spring 11″ src=”http://uwant2gogo.file …
    ^
    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
    line 28, column 141: Unregistered link relationship: search [help]
    … ss.com/osd.xml” title=”U Want 2 GoGo” />
    ^
    line 281, column 2023: content:encoded should not contain relative URL references: http://www.wigwammotel.com [help]
    … =&feed=1″ width=”1″ height=”1″ />]]></content:encoded>
    ^

    #762400
    #762403

    gogohanneson
    Member

    Thanks, Sacred Path. Yes, I went into both posts and added then deleted a space, then put this http://uwant2gogo.wordpress.com/feed/ in Feed Validator.

    The same three messages came up.

    #762410

    There is stuff in those posts that is messing things up.

    Do you use some other program for creating your posts, or do you use the wordpress editor?

    #762411

    gogohanneson
    Member

    I accidentally did something to WordPress so everything is really tiny and I can’t read it so my very last post I did in Word and then cut and pasted but it was messed up so I retyped it. Otherwise, I always create in the wordpress editor.

    #762416

    raincoaster
    Member

    DO NOT POST FROM WORD.

    That’s one of the most common causes of problems online. Edit that post, change something, anything, and then Update it.

    #762420

    I’m afraid I’m out of suggestions at this point. Wait till Monday and contact staff directly at http://en.support.wordpress.com/contact/ , enter your question, then click the “no…” button and fill in the rest of the information.

    #762422

    gogohanneson
    Member

    Thanks, raincoaster. I did change something in the post that I added from Word but it didn’t make a difference. Then I realized that I’d published that post after I got the message about the RSS feed. So this time, at least, it wasn’t the Word doc. I won’t be doing that again, though.

    Thanks also for all your help, thesacredpath. I’ll wait until Monday and contact the staff directly, per your suggestion.

    Have a good rest of the weekend.

    #762423

    You are welcome and you too.

    #762739

    Sometimes, a strange character gets added into a post and it can cause strange validator things to happen because the validator is not expecting character types other than the one specified in the html header. It’s hard to say how an odd characters can get in there, but pasting from Word is one possible culprit. If you can see a way to reproduce the problem, let me know the steps and I can test it too. It seems to happen fairly rarely, but I’d be happy to look into it a bit more if anyone can figure out how to reproduce the trouble.

    When it happens, you can pinpoint where the unexpected character is by looking at a feedvalidator.org report like this one (already fixed for this blog): http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fuwant2gogo.wordpress.com%2Ffeed%2F

    I used that report to see what part of the content had the funny character, then I scrolled up a little to see what post it was in. In this case, it was in the “NO COACHELLA? NO PROBLEM. You have SO much to do here in town….” post. Then I opened the post for editing in html mode and manually re-typed over the text that was hightlighted by feedvalidator.org and saved. Now when I check the feedvalidator.org report, it shows “This is a valid RSS feed.” The few warnings after that shouldn’t affect the ability to use the feed.

    Can you try the feed again now?

    #762754

    gogohanneson
    Member

    Thanks, designsimply!

    Just to be sure, I try the feed by typing http://uwant2gogo.wordpress.com/feed/ into http://feedvalidator.org/check.cgi

    Correct?

    #762761

    timethief
    Member

    The feed now validates. Please see the other thread here > https://en.forums.wordpress.com/topic/contacting-support-8?replies=10#post-756109

    #762762

    gogohanneson
    Member

    Thank you so much to everyone for all the help!!!!

The topic ‘Broken RSS feed’ is closed to new replies.