Browser settings – homepage not loading correctly

  • Author
  • #1337326

    Home page not loading on Chrome

    The Traceroute for my mac:
    traceroute to (, 64 hops max, 72 byte packets
    1 ( 4.829 ms 1.430 ms 1.408 ms
    2 ( 6.218 ms 2.408 ms 2.390 ms
    3 ( 17.701 ms 27.847 ms 17.957 ms
    4 ( 26.860 ms 23.234 ms 12.007 ms
    5 ( 13.315 ms 99.666 ms 8.550 ms
    6 ( 161.101 ms 159.049 ms 167.293 ms
    7 ( 161.956 ms ( 164.907 ms ( 146.669 ms
    8 ( 98.014 ms ( 75.741 ms ( 69.967 ms
    9 ( 66.239 ms ( 66.338 ms ( 73.463 ms
    10 ( 66.684 ms 67.509 ms 76.241 ms

    The blog I need help with is



    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.



    Hi there, could you please confirm that this is the site that isn’t loading for you:

    Does it load in another browser, like Firefox or Safari?

    Are you able to load the homepage?

    Have you tried another network/ISP? For example, if you’re having trouble at home, could you try a cafe or library?

    In what country are you located?



    That is indeed the site.

    Here is the homepage screenshot:

    The problem only occurs with my Chrome browser, not with Safari or Firefox, for instance. I cleared the cache, and have tried various networks and locations, so I’m not sure if the problem lies within my Chrome application, or something else – I’m currently abroad for the month in Colombia. It seems that other people that view the homepage don’t have the same issue as I do, so I’m not as concerned. Hoping that the problem will fix itself over time.. unless you happen to know what else could be wrong?





    Hi there, from the screenshot, it looks like your page is loading, but there are some display issues.

    Could you please try turning off all your Chrome extensions and add-ons, as Timethief suggested in the other thread, and restarting the browser? It’s possible that one of them is interfering.

    Here are instructions for doing that:

    Scroll down to the section called “Temporarily disable extensions.”

    If the problem goes away, you can try reactivating the add-ons/extensions one-by-one to find the culprit that’s been inserting the ads.

    Let me know how it goes.


    I did a clean re-install of Chrome, and now everything works as it is supposed to woohoo!

    Thank you so much timethief, kathrunwp, and lorelle for all of your help!!



    Glad you got it sorted out, thanks for letting us know!



    Hooray! This is such good news. Best wishes for trouble-free blogging.

The topic ‘Browser settings – homepage not loading correctly’ is closed to new replies.