BUG: Caption text edit is not global

  • Author
  • #863783


    I’m in the process of setting up a travel blog, and after scanning most of the templates, I ended up with the Adventure Journal, due to it’s wide column w/large pics, and nice menu setups.

    There are a few problems, though. Lots of issues with consistency of how pics are displayed in posts/streams over the different template settings; it seems like all templates have their own bugs and quirks there, but now I’m struggling with the Adventure Journal:

    To post a pic that’s large enough, I’ll have to choose the “Photo” mode, and not post a regular blog post. When choosing to post a photo directly, I get the option of adding a caption – which can be used as a regular blog post text. There is no way of adding categories while making the photo post, so I’ll have to go back to the post and edit in order to get the categories in place. Cumbersome, but no bug.

    The real problem arises when I need to edit the text for typos and stuff like that, or just to add something (like we always do….)

    The change is updated and visible on the front page (shows the most recent posts), and on the individual post view (by clicking the post title).


    The change is NOT visible when viewing the posts through clicking on categories or tags. This means that you can’t navigate through the drop-down menu I made to see the updated post……. huge bug, and impossible to work with.

    Failed fixes: I’ve tried editing the post from all available access points, and the title can be edited – not the text, however. I’ve also tried changing the unique photo URL. Then, the photo will (not surprisingly) disappear on the front page listing and in the unique view (where the share buttons are visible), but the photo will NOT disappear on the tag and category streams……. it seems that it’s been made a separate and unaccessible “first version” of my “Photo” blog post, which can not be edited, other than the title itself.


    Is there a way around this, so that I can edit existing posts for the tag listings and category menus, or do I have to delete the existing post, and make a new one from scratch ….. each time I need to edit the text……?

    And when deleting a post like that, does that mean that I can only delete/remove the indexable title + most recent version of the pic/caption, but that the “untouchable” version of the pic/caption will be impossible to delete completely, and because of that gradually fill up my storage….?

    Sorry for the long question, but I guess it’s needed to make things clear. Lastly, a few links:

    Unique view of post (can be edited): http://globehobo.com/2012/04/07/testing-editing-bug/

    “Tag stream” view of posts, here with the tag “Tiger” (post can not be edited, except from the title itself): http://globehobo.com/tag/tiger/

    “Category stream” wiev of posts, here with the category “Norway” (post can not be edited, except from the title itself): http://globehobo.com/category/i-was-here/europe/norway/

    See also the navigable menu at the top of the webpage; that’s an essential way of finding posts – but posts you’ll find there can not be edited.


    The blog I need help with is globehobo.com.


    Hi, stuvland. It sounds like you have posts that are showing different stages of edited content on the home page, single post pages, and archives. Is that correct? I’m not seeing any that can’t be edited or are showing different content. Has everything been sorted out?



    That’s correct. The home page was updated, single post pages and archives weren’t. I deleted the post I used as an example a few hours ago, so you might not have been able to see the problem for yourself.

    I did solve it, though:

    The theme (Adventure Journal) allows for “Photo” posts to show up with both texts and photos in the Archive listing of posts (sorted by Category or Tag), which I like a lot (that’s part of the reason why I chose that layout). The problem, however, is that the Excerpt field was used to “auto publish” the first version of the post contents upon publishing the post, in order to add a source code that allowed for photo displays there as well.

    When I later edited the text, the Excerpt field would stay the same, and for that reason, the Archive posts would remain unchanged.

    Solution: Edit both the “regular” window and Excerpt window when making changes to the post.

    Thanks, anyway!

    (by the way, do you know any way of making slideshows visible in the Archive listings, same way as the different source code in Excerpt makes photos visible there? And I’d also like the “Read More” function to work there… the texts can get long).



    Kind of messy explanation there. :p

    Well – in short: The Excerpt field had a piece of auto-generated source code to display photos in Archive listings of posts (I see that other themes won’t display photos there), and I didn’t update that code when editing posts. That way, that source code would “override” my edits.

    I’m now changing that part as well, and all is fine.



    Hi stuvland,

    I’m glad you have sorted things out. If you have any more questions please let us know.

The topic ‘BUG: Caption text edit is not global’ is closed to new replies.